We help IT Professionals succeed at work.
Get Started

Ethernet controller having issues (Code 1, Code 28, Code 31) Windows 7

2,569 Views
Last Modified: 2013-11-09
Hi,

Just recently I've been having issues with my Ethernet controller.

This is what my device manager looks like
 Device Manager
It is a integrated Marvell Yukon 88E8056 Gigabit Ethernet controller on a ASUS P6T Deluxe V2 motherboard.

No matter what drivers I try to use, it refuses to work.

Here are some of the errors Device Manager shows
 Marvell Yukon 88E8056 Error Code 1 Marvell Yukon 88E8056 Error Code 28 Marvell Yukon 88E8056 Error Code 31
and here's some snapshots of Speccy
Speccy snapshot of Summary Speccy snapshot of the Network
This problem may have to do with the fact that my Network Connections has looked like this for months.
Network Connections
I've tried everything I could find in Google, even attempted a repair install (After hours of during the upgrade, it failed)

I do NOT have a System Restore (disabled) or anything of that nature. Reformatting is NOT an option.

500 points to whoever can solve this in a timely fashion.
Comment
Watch Question
This problem has been solved!
Unlock 1 Answer and 12 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE