We help IT Professionals succeed at work.

Initialization Failed; Can't access EMC or EMS

lspringman
lspringman asked
on
Hey guys, something as occur today for this to happen. Everything was working fine yesterday and now today boom.. getting these error messages. The Exchange server is using a 3rd party certificate installed. It looks as if it can't find the FQDN or the CAS server name. I'm not sure exactly how to fix this issue, I had a friend helping me try to fix activesync on this server.
Attached below is the errors.
First were were getting the error in activesync properties in the EMC, then when we closed out, could not get back in.
Please, Please, Please, can anyone help. :)
 Error from event viewer Error from EMC   Error from EMS
Comment
Watch Question

BusbarSolutions Architect

Commented:
can you make sure that powershell virtual directory exists and you cann access it and bound to port 80
if yes I am afraid the the only solution is to re-install CAS
AkhaterSolutions Architect

Commented:
Can you please make sure that the time on the server is correct and in sync with the domain controller ?

Author

Commented:
Akhater: Yes the time zones are in sync with the domain controller

Author

Commented:
busbar:I am unable to access it, infact when I was going into IIS to make sure there wasn't a redirect, I get this error message.

In the Powershell directory, I do have a web.config file and a web.config.bak
Those are the only two files located under there.
powershell-error-1.jpg

Author

Commented:
Note, I did run these commands from Microsoft article the following night of me discovering this error
http://support.microsoft.com/kb/940726
To resolve this issue, modify the URLs for the appropriate Exchange 2007 components. To do this, follow these steps:

   1. Start the Exchange Management Shell.
   2. Modify the Autodiscover URL in the Service Connection Point. The Service Connection Point is stored in the Active Directory directory service. To modify this URL, type the following command, and then press ENTER:
      Set-ClientAccessServer -Identity CAS_Server_Name -AutodiscoverServiceInternalUri https://mail.contoso.com/autodiscover/autodiscover.xml
   3. Modify the InternalUrl attribute of the EWS. To do this, type the following command, and then press ENTER:
      Set-WebServicesVirtualDirectory -Identity "CAS_Server_Name\EWS (Default Web Site)" -InternalUrl https://mail.contoso.com/ews/exchange.asmx
   4. Modify the InternalUrl attribute for Web-based Offline Address Book distribution. To do this, type the following command, and then press ENTER:
      Set-OABVirtualDirectory -Identity "CAS_Server_name\oab (Default Web Site)" -InternalUrl https://mail.contoso.com/oab



I'm thinking maybe this is what messed it up, something was inputted incorrectly.

Author

Commented:
busbar: reinstalled CAS, still no workie
BusbarSolutions Architect

Commented:
Hi
can you make sure that all of the IIS components required for Exhcange is installed as per this article
http://technet.microsoft.com/en-us/library/bb691354.aspx
1. make sure IIS WinRM extension is installed
2. open powershell and run command : WinRM Quickconfig
3. Open IIS go to Powershell virtual directory and check that SSL in disabled and authentification is set only to Anonymous
try again.
if not uninstall the CAS, make sure the prerequisities are there, and install again
Well, I had to talk to Microsoft, but a guy there fixed the issue.
The problem was a web.config file in directory c:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell
The file was corrupt, it was missing a lot of info. He sent me a replacement file, and now it all works great. Best thing to do is if this problem happens, restore this file from a backup.