We help IT Professionals succeed at work.

PAE in boot.ini doesnt make RAM available on Dell 2900/2950 Win2k3 Ent Server

I have 2x Dell Servers. A 2900 and a 2950 both running Windows 2003 Enterprise
The 2950 has 32GB RAM. The 2900 has 12GB RAM. For the purposes of this question i will use the 2950 as my example but both do exactly the same thing

If i run WINMSD it says Total Physical Memory is 32,768 MB but available is 3.6 GB
In Task manager (Performance tab) Total Physical memory is 33548936K, and available is 29087100 (or thereabouts).
If i run perfmon, the availabel memory never fluctuates from around 28GB which seems to tie in with winmsd in saying i only have 4 GB being used and 28 sitting there - potentially available - but not being used
This is an SQL server so we need to use all available memory (that was the point of getting 32GB RAM in the first place)
The 2900 server is an identical system that i use for testing. I have tried /PAE in boot ini with and without various other switches that turn on/off DEP (ie optin/optout). Have tried /MAXMEM.

I have now put a RAM soak tester on the test box and it never uses more than 3.6 GB of the 12 available physically.

This seems to me to be hardware related since i have done this on HP kit before and addition of /PAE gave me 16GB RAM availabel after a single reboot.

Are Dells capable of using RAM over 4GB in W2K3 R2 SP1 /2 ?? I'm stuck...... please help :-(

Thanks
Comment
Watch Question

Distinguished Expert 2019

Commented:
Perfmon wouldn't see 36GB total if windows couldn't see all the RAM. Many memory testers are limited to RAM below 4GB.

I'm pretty sure WinMSD available memory only shows memory available to Windows which is 32 bit so doesn't show RAM above 4GB as available, e.g. It can assign memory above 4GB to SQL 32 bit but that RAM isn't available to Windows itself.


How much RAM is shown in system properties?

Author

Commented:
32 GB Shown in system properties (it also says Physical Address Extensions). I can demonstrate though, that the system only uses 4GB of RAM and nothing above that

I have done the same thing on an HP Proliant server and it shows both the Physical and available physical as 12GB and 11.5 GB respectively. It just seems to be the Dells it doesnt work on.

perfmon shows a steady line of 28 GB available but all other counters max out at 4GB mark when under load and then the pagefile kicks in so it definitely isnt "seeing" the RAM above 4 GB as available to system

Author

Commented:
going to put SP2 on and see if it makes a difference....

Commented:
PAE makes memory above 4GB available to the system. The total will be reported as Physical Memory - Total in Task Manager. If this memory is not actually being used that is another matter entirely, it has nothing to do with PAE.
Distinguished Expert 2019

Commented:
>I can demonstrate though, that the system only uses 4GB of RAM and nothing above that

Demonstrate using what? Only applications that use AWE such as SQL will use the RAM above 4GB, if you're using multiple instances of something that doesn't use AWE they'll all have to cram into the address space below 4GB.
i'm using a soak tester called BurnInTest.

I just installed SP2 and i can now see all the memory and it is available to the system (this has solved my problem since the live SQL server will now be able to use more than the 1.7 GB its currently limited to)

You're correct about AWE apps by the looks of it. When i run the SOAK test though, it still only fills the first 4GB RAM as you have correctly pointed out.

Next step is upgrading the Dev version and VM versions of the server (we take livestates of it every night) to make sure SP2 doesnt break anything else, then hopefully, SQL can spread its legs while the other non-AWE apps fight for space under 4GB

Result!!
Distinguished Expert 2019

Commented:
Ah, different versions of burnintest by the looks of it, see note 6 at http://www.passmark.com/products/bit_editions.htm