We help IT Professionals succeed at work.

Disable PostFix Delivery notification

jackdaniel_china
on
Hello
I would like to disable the delivery notification in a postfix server.
the delivery for the users (if they select the option "request a Delivery Receipt" in outlook for example and send one email to my server that the server do not reply with the "Your message was delivered to the recipient."
I already used the
smtpd_discard_ehlo_keywords = silent-discard, dsn
but it seems it works only for internal messages.
is there any way to disable it at all?
thanks
Comment
Watch Question

Top Expert 2005

Commented:
First of all, it's not postfix, who sends the delivery notification, but recipient(or it's MUA automatically).
What You could try, is removing delivery notification headers from relayed emails.
http://www.posluns.com/guides/hedrem.html
The header in subject is Disposition-Notification-To, probably Disposition-Notification*

Author

Commented:
thank you ravenpl
I made many tests and I found out that DSN's are requested at the time of sending by the sending application or server software (not anyplace inside the email or headers itself).
DSNs are requested at the end of the RCPT TO: command (eg: RCPT TO:<> NOTIFY=SUCCESS,DELAY) and the MAIL FROM: command (eg: MAIL FROM:<> RET=HDRS)

I still did not find a way to cancel this notification.
thanks

Author

Commented:
anyone has any idea?
Top Expert 2005

Commented:
Try disabling the DNS from ehlo. If server will not announce the DSN support, the client should not use it.
And actually postfix rejects any DSN after that.

I have in the main.cf
smtpd_discard_ehlo_keywords = silent-discard VRFY ETRN DSN

Author

Commented:
thanks Raven
unfortunately looks like it does not work 100%

I test emails from hotmail.com to my server, I did not got the delivery notification
I test using another ISP and I got as below, is there anything else I could do to prevent this kind of delivery notification ?

Reporting-MTA: dns;hm1480-23.xxx.com
X-PowerMTA-VirtualMTA: lw_filtro_rcpt_t
Received-From-MTA: dns;hm2084.xxx.com (xxx.xxx.xxx.xxx)
Arrival-Date: Mon, 16 May 2011 06:40:43 -0300

Original-Recipient: rfc822;tomlee@yyy.com
Final-Recipient: rfc822;tomlee@yyy.com
Action: relayed
Status: 2.0.0 (success)
Remote-MTA: dns;mx.yyy.com (yyy.Yyy.yyy.yyy)
X-PowerMTA-BounceCategory: success
Top Expert 2005
Commented:
According to http://www.postfix.org/DSN_README.html this should disable DSN.
Try telneting to Your host and verify it supports DSN or not - it should look like

[raven@server /]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 xyz.com ESMTP
ehlo localhost
250-xyz.com
250-PIPELINING
250-SIZE 40960000
250-STARTTLS
250-ENHANCEDSTATUSCODES
250 8BITMIME
mail from: <raven@xyz.com> RET=HDRS
501 5.7.1 DSN support is disabled
mail from: <raven@xyz.com>
250 2.1.0 Ok
rcpt to: <raven@xyz.com> NOTIFY=SUCCESS,DELAY
501 5.7.1 DSN support is disabled

Author

Commented:
In my browser it does not show what are the boxes to select, so I select the first one supposing that it's the best grade.