We help IT Professionals succeed at work.

iPhone & OWA & SSL

I am trying to configure SSL for OWA.

I created a certificate as per http://www.msexchange.org/tutorials/SSL_Enabling_OWA_2003.html

then followed these steps

Then I had to follow this Microsoft KB article: http://support.microsoft.com/?kbid=817379

Then I  to install a hotfix: http://support.microsoft.com/kb/916640

On the PC Explorer and Firefox I receive a message secure connection failed

An error occurred during a connection to mail.test.co.uk.

Certificate type not approved for application.

(Error code: sec_error_inadequate_cert_type)


On Safari on the iPad I can access OWA and logon fine.
I am unable to configure the iPhone and the iPad.
Does anyone have any ideas on how I resolve these issues?
Comment
Watch Question

Co-Owner
Top Expert 2011
Commented:
I take it you have Exchange 2003 as you have referenced KB817379 which is a 2003 article?
If that is the case, please have a read through my Exchange 2003 / Activesync article which should be all you need to get you up and running happily.  It has the relevant IIS settings, pre-requisites, tests and solutions for errors if you get any.
http://www.experts-exchange.com/articles/Software/Server_Software/Email_Servers/Exchange/Exchange-2003-Activesync-Connection-Problems-FAQ.html 

Author

Commented:
Thanks Alan. I could not get it to work.

Which folder do I enable SSL so that I can use https from any browser?
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Are you running on SBS 2003 or do you just have Exchange 2003?
Have you bought a 3rd party SSL certificate or are you using a self-signed certificate?
A 3rd party SSL certificate will ony cost you £30 for a year.

Author

Commented:
I regenerated a self-signed certificate. Now ssl works on the browser and the iphone

Alan is the push mail in Active Sync enabled by default?
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Yes, but there are various places it can be disabled.
The phones can be set to Push / Pull and the server can be configured Globally and on the individual user accounts.

Author

Commented:
I guess it's best to set it globally.

Where can I set this up in Exchange Manager?

Thanks
Alan HardistyCo-Owner
Top Expert 2011
Commented:
Globally it is configured using Exchange System Manager and then Global Settings> Mobile Services Properties.
Alan HardistyCo-Owner
Top Expert 2011

Commented: