We help IT Professionals succeed at work.

Opening Cisco's New GUI?

Bardlebee
Bardlebee asked
on
Hello,

I recently purchased an Cisco 1811: http://www.newegg.com/Product/Product.aspx?Item=N82E16833120005&Tpk=cisco%201811

I was wondering if this item has a GUI on it, I was assured of this via the salesman. I have only gotten my CCENT in the last 6 months, so I am not an expert with the CLI, however that does not mean if I was thrown a bone I could configure this router to work.

I am hoping that someone knows how to configure the CLI so that I can access the GUI. Therefore after this I can configure it via the GUI, but also see what the commands are in CLI giving me a good learning experience.

Does there need to be a CLI setup before I can access the GUI? If so/not then how do I access the GUI in the first place. This was not really covered in what I had read and learned previously.
Comment
Watch Question

Commented:
Asuming that the 1811 is like the 2811s that I use then the Fa0/0 interface is usually pre-configured with a 10.10.10.1/29, so configuring a PC on that network and pointing your browser to 10.10.10.1 should access the web gui.

Be aware that it only works on Internet Explorer.

If that doesn't work go into the console and in exec config mode try this

Router# configure terminal
Router#(config) ip http server
Router#(config) ip http access-class 23
Router#(config) ip http authentication local
Router#(config) access-list 23 permit 10.10.10.0 0.0.0.7

The access class and access-list are not really required, but that'd how it's setup in the default config.

There should be a default username/password setup as cisco/cisco whcih should give you exec access, if that user isn't setup the issue the following commands i the CLI

Router#(config) username cisco password cisco privilege 15

If your network isn't setup then the following commands will configure it for you

Router#(config) interface fastethernet 0/0
Router#(config-if) ip address 10.10.10.1 255.255.255.248

With the above configured you should be able to access the Cisco web based GUI.

Commented:
Oh and remember to write the config as you'll lose it if you power cycle the router :-)

Author

Commented:
Man, its been so freaking long....

How do you write to config again?

I am slowly remembering how to work with it again (such as entering enable/config/int modes and others) but that's the one I forgot. hah...

I will probably look it up real quick. I am going to work on this and respond on Monday being the latest to give you an update. Thank you.

Author

Commented:
Router#(config) ip http access-class 23
Router#(config) ip http authentication local
Router#(config) access-list 23 permit 10.10.10.0 0.0.0.7

I followed you up until these three lines. I did these lines but I just want clarification of what they mean... for educational purposes.... if you don't wanna bother explaining maybe you can recommend a cisco document....

access-list 23 permit 10.10.10.10 0.0.0.7= My assumption here is that this 'access-list' as in this group of people in 10.10.10.0 are granted access-list level 23? But what is access-class 23? Why 23?

Also, I assume 'ip http authentication local' means that one can only use the browser (http protocol) for the SDM in the local network. For instance, my network that I am placing this in is 192.168.2.0, would this change the 10.10 IP being that this will be my main/only router for this location?

Upgrading points due to extra questioning, also I found out how to save again... ugh its all coming back to me.

Author

Commented:
Here is my startup-config for reference and where I am at:


#sh startup-config
Using 1244 out of 196600 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname West-STSC
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$I.my$wcLXUSvq9ql7ava8DnYh//
enable password css1940
!
no aaa new-model
!
!
dot11 syslog
no ip routing
!
!
no ip cef
!
!
!
multilink bundle-name authenticated
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 ip address 192.168.2.40 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Async1
 no ip address
 encapsulation slip
 no ip route-cache
!
ip forward-protocol nd
!
!
ip http server
ip http access-class 23
ip http authentication local
no ip http secure-server
!
access-list 23 permit 10.10.10.0 0.0.0.7
snmp-server community public RO
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
line aux 0
line vty 0 4
 password (redacted)
 login
!
end

Open in new window

Author

Commented:
Reporting back on what I have done:

I am hitting a wall, I have implemented exactly what you said and I still can't get the GUI.... strange
Commented:
Hi

Make sure you have Java 6 update 7 and make sure internet explorer is yours default browser as SDM will only work with these.

iam studying for CCNA and here is how i do it see below screencast.

Cheers
acl-puzz-315722.flv

Author

Commented:
I think I screwed this up by messing with it. This will all look stupid when I start working on my CCNA, haha. I was so good back when I got my CCENT :(

here is my code:


service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname West-STSC
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$I.my$wcLXUSvq9ql7ava8DnYh//
enable password css1940
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-3872896560
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3872896560
 revocation-check none
 rsakeypair TP-self-signed-3872896560
!
!
crypto pki certificate chain TP-self-signed-3872896560
 certificate self-signed 01
  3082024F 308201B8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383732 38393635 3630301E 170D3130 30363131 32303239
  31355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38373238
  39363536 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100CB1A BEDCE900 84D7C51D 85230D8A D2D84DAC 6E96A5AC E939E09C 17B702BF
  F9425A71 BEE2335C C1BE6312 AA83FDE0 61E13A08 A8B16304 F0363ABD F4F66EF7
  5626AF40 33651C1A 187284D7 6F296050 0F415EDB 9206A576 289015D8 0B77953D
  E2869667 B14EE6AB EDD38B01 3DB0E6FD B978602A FBFD30FB 513FAFFE 6ED83124
  E31D0203 010001A3 77307530 0F060355 1D130101 FF040530 030101FF 30220603
  551D1104 1B301982 17576573 742D5354 53432E53 5453432E 696E7465 726E616C
  301F0603 551D2304 18301680 14ABAB6C 41A2A24E CF2AB356 1D321C67 4576F95C
  C2301D06 03551D0E 04160414 ABAB6C41 A2A24ECF 2AB3561D 321C6745 76F95CC2
  300D0609 2A864886 F70D0101 04050003 818100AF 49904D92 30EB4FC2 7EC39D87
  61E740B6 DEED9ED1 DB2E956F 803F7A46 6696E0E6 134AF5F1 29BA1EFD A47FAD96
  104CC705 F6E56704 1D6497FA 86B7FA2B D749ABF5 CD6E9783 7EE1346A 97B3CF0A
  64EA250E 2B5869AA C8ACA69B 64C43311 03AB692C E34A1CFE 6521BFCC 340E5C4B
  ED559C15 34899524 57E62D41 D9E3906C 5C1BA5
        quit
dot11 syslog
no ip routing
!
!
no ip cef
no ip dhcp use vrf connected
!
ip dhcp pool WestUsers
   network 192.168.2.0 255.255.255.0
   domain-name WestUsers
!
!
ip domain name STSC.internal
!
multilink bundle-name authenticated
!
!
username cisco password 0 cisco privilege 15
username Admin privilege 15 password 0 Admin!!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 ip address 192.168.1.110 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 no ip route-cache
 duplex auto
 speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
 ip dhcp client update dns
!
interface Vlan1
 no ip address
 no ip route-cache
!
interface Async1
 no ip address
 encapsulation slip
 no ip route-cache
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
!
snmp-server community public RO
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 privilege level 15
 password Admin!!
 login local
 transport input all
line vty 5 16
 privilege level 15
 login local
 transport input all
!
end

Open in new window

Author

Commented:
Here is an 'sh ip int brief':


Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              192.168.1.110   YES NVRAM  up                    up
FastEthernet1              unassigned      YES NVRAM  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
FastEthernet4              unassigned      YES unset  up                    down
FastEthernet5              unassigned      YES unset  up                    down
FastEthernet6              unassigned      YES unset  up                    down
FastEthernet7              unassigned      YES unset  up                    down
FastEthernet8              unassigned      YES unset  up                    down
FastEthernet9              unassigned      YES unset  up                    down
Vlan1                      unassigned      YES NVRAM  up                    down
Async1                     unassigned      YES NVRAM  down                  down

Open in new window

Commented:
One other thing that you need to check is that you have the web file son your router. Below is a dir of the flash: disk on my 1841 at home. Without these the web interface wont work.

1DHFC#dir
Directory of flash:/

    1  -rw-    16926800   Sep 4 2007 19:53:54 +00:00  c1841-broadband-mz.124-16.
bin
    2  -rw-        1821   Sep 4 2007 20:13:12 +00:00  sdmconfig-18xx.cfg
    3  -rw-      861696   Sep 4 2007 20:13:32 +00:00  es.tar
    4  -rw-     1164288   Sep 4 2007 20:13:56 +00:00  common.tar
    5  -rw-        1038   Sep 4 2007 20:14:16 +00:00  home.shtml
    6  -rw-      113152   Sep 4 2007 20:14:34 +00:00  home.tar

31916032 bytes total (12832768 bytes free)
1DHFC#

Author

Commented:
Well, I can't seem to ping and I still have that configuration shown above... truly weird.

Commented:


Where exactly you are having problem?

 and have you configured exactly what is shown in screencast with all requirements mentioned?

Author

Commented:
I am having a problem just pinging period. Also, if I connect my laptop to the router Fastethernet 9 port I don't get an IP assigned to my PC. So, my 'do ping 192.168.1.1' does not work and I cannot ping it via my computer either...



I started off clean by doing a 'write erase' and reloading this is my config now:


Building configuration...

Current configuration : 2792 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WG-STSC
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-3872896560
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3872896560
 revocation-check none
 rsakeypair TP-self-signed-3872896560
!
!
crypto pki certificate chain TP-self-signed-3872896560
 certificate self-signed 01
  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383732 38393635 3630301E 170D3130 30363134 31393439
  33325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38373238
  39363536 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BE8A B5790460 A9253C5A 38A1933A 19925684 71E3593E F352827B CA66CCC1
  024EEC73 63C2FB7E DE069B52 F335D5EA A1A0839F A9E6104E EC45ABFA 8DA03006
  BD0FE01F 35D15726 8D8E23E5 21BCD930 D220CE65 4528F3DC BA15C82F 4720549B
  5EA44127 8DA7E630 EC359BC4 502C5E31 9DC8DA5E FF3D0393 DE10ED8D BC0013F5
  2FD30203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603
  551D1104 13301182 0F57472D 53545343 2E57472D 53545343 301F0603 551D2304
  18301680 14176C5B C22E35E8 A6023099 04DA1806 31A77880 D9301D06 03551D0E
  04160414 176C5BC2 2E35E8A6 02309904 DA180631 A77880D9 300D0609 2A864886
  F70D0101 04050003 81810005 7C240380 C38B08A1 C84C693E B557F4F9 1ED9449D
  F0C861A2 1560C276 F3E588C5 0F0E3D67 538C7881 AECDF968 6EB728DD 4F8964CC
  360DF0CD E624AF2B AD2AD768 C3895AC3 42F77084 062A95F4 2774166B A88CDB2D
  A151FEE9 813D74A6 3527789E 3CF0E88A D74D6821 670B3873 A6BD4B4C 96CF32DF
  23E8372E 98F7813D 2545D6
        quit
dot11 syslog
!
!
ip cef
!
!
ip domain name WG-STSC
!
multilink bundle-name authenticated
!
!
username admin privilege 15 password 0 admin
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface FastEthernet0
 ip address 192.168.1.110 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
!
interface Vlan1
 no ip address
!
interface Async1
 no ip address
 encapsulation slip
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input all
line vty 5 16
 privilege level 15
 login local
 transport input all
!
end

Author

Commented:
I guess it should be specified that I don't have this router connected to the internet in any way. I just have the ethernet cable going to my laptop and a COM cable going to the console port.

Commented:
so the issue is you can communicate from Fa port to yours computer check this things

You shold use cross over cable

make sure you see  "FastEthernet0/0 is up, line protocol is up (connected)" after issuing "sh int fa0/0" command

make sure you have issued no shut command

try using different Ethernet ports

these are common ideas i can think if u cant ping router<--->PC

Commented:
Sorry typo mistake above first line ;-) right line is here


so the issue is you cant communicate from Fa port to yours computer? check this things

Author

Commented:
Well no, the issue is both.

When I am doing like you did in the video, I do a 'do ping 192.168.1.1' and I don't get any hits. Also I cannot ping with windows command...

I need a crossover cable for this? I believe I am just using a straight trhough.

Author

Commented:
Should I be connecting the cable to FastEthernet 0?

Does it matter? I have it connected to FastEthernet 8 right now..
Commented:
OK I think your problem here is the fact that you have configured an IP address onto interface FastEthernet0, and you are connecting your PC to port 8. I would take of the IP address from port 0 and instead set the IP address on VLAN1, as all ports are part of VLAN1 by default.

Try this

Router# config terminal
Router(config)#interface fastethernet0
Router(config-if)#no ip address
Router(config-if)#interface VLAN1
Router(config-if)#ip address 192.168.1.110 255.255.255.0
Router(config-if)#end
Router#write

Also the reason that your PC isn't getting an IP address is that you dont have a DHCP server setup on your router to do this you will need the following commands

Router(config)#service dhcp
Router(config)#ip dhcp pool 192.168.1.0/24
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.100
Router(dhcp-config)#exit
Router(config)#ip dhcp excluded-address 192.168.1.100
Router(config)#end
Router#

This last command excluded 192.168.1.100 (your router IP address) from the DHCP pool, if you wanted to restrict DHCP allocated IP addresses to say 192.168.1.1 - 32 then you exclude all others by changing the last line to

Router(config)#ip  dhcp excluded-address 192.168.1.33 192.168.1.255

Author

Commented:
It looks like I do not have the SDM files on my router... right now I am able to ping my router thanks to your help... however when I load the SDM I use 192.168.1.1 and it gives me the following error I attached here. Also, I attempted to connect via the SDM install to install it, but I get the following error as well.

It should be noted, my PC was granted the IP 192.168.1.1 since I imagine it was the first available in the pool... would this cause the conflict? Should I exclude 192.168.1.1 then try again?

error.jpg
save.jpg

Author

Commented:
An update:

I changed my IP to a static on my PC to 192.168.1.20. I then attempted to ping the following:

192.168.1.1: Ping couldn't reach
192.168.1.100: Ping couldn't reach
192.168.1.20: Ping worked.


It would seem that the only thing I can ping from both my PC and router is my computers IP address... which means my PC for some reason cannot ping the router still, but the router can ping my PC..... is there a setting to setup the routers IP?

Here is what my config looks like now:


Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES manual up                    down
FastEthernet1              unassigned      YES NVRAM  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
FastEthernet4              unassigned      YES unset  up                    down
FastEthernet5              unassigned      YES unset  up                    down
FastEthernet6              unassigned      YES unset  up                    down
FastEthernet7              unassigned      YES unset  up                    down
FastEthernet8              unassigned      YES unset  up                    down
FastEthernet9              unassigned      YES unset  up                    up  
Vlan1                      192.168.1.110   YES manual up                    up  


Building configuration...

Current configuration : 3230 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WG-STSC
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-3872896560
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-3872896560
 revocation-check none
 rsakeypair TP-self-signed-3872896560
!
!
crypto pki certificate chain TP-self-signed-3872896560
 certificate self-signed 01
  30820247 308201B0 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 33383732 38393635 3630301E 170D3130 30363134 31393439
  33325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 38373238
  39363536 3030819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100BE8A B5790460 A9253C5A 38A1933A 19925684 71E3593E F352827B CA66CCC1
  024EEC73 63C2FB7E DE069B52 F335D5EA A1A0839F A9E6104E EC45ABFA 8DA03006
  BD0FE01F 35D15726 8D8E23E5 21BCD930 D220CE65 4528F3DC BA15C82F 4720549B
  5EA44127 8DA7E630 EC359BC4 502C5E31 9DC8DA5E FF3D0393 DE10ED8D BC0013F5
  2FD30203 010001A3 6F306D30 0F060355 1D130101 FF040530 030101FF 301A0603
  551D1104 13301182 0F57472D 53545343 2E57472D 53545343 301F0603 551D2304
  18301680 14176C5B C22E35E8 A6023099 04DA1806 31A77880 D9301D06 03551D0E
  04160414 176C5BC2 2E35E8A6 02309904 DA180631 A77880D9 300D0609 2A864886
  F70D0101 04050003 81810005 7C240380 C38B08A1 C84C693E B557F4F9 1ED9449D
  F0C861A2 1560C276 F3E588C5 0F0E3D67 538C7881 AECDF968 6EB728DD 4F8964CC
  360DF0CD E624AF2B AD2AD768 C3895AC3 42F77084 062A95F4 2774166B A88CDB2D
  A151FEE9 813D74A6 3527789E 3CF0E88A D74D6821 670B3873 A6BD4B4C 96CF32DF
  23E8372E 98F7813D 2545D6
        quit
dot11 syslog
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.100
!
ip dhcp pool 192.168.1.0/24
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.100
!
!
ip domain name India.com
!
multilink bundle-name authenticated
!
!
username admin privilege 15 secret 5 $1$okPG$sSaKRYxgE8z7A/oZYTN9k0
!
!
archive
 log config
  hidekeys
!
!
!
!
!
interface Tunnel1
 no ip address
!
interface FastEthernet0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet1
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
 speed 100
!
interface Vlan1
 ip address 192.168.1.110 255.255.255.0
!
interface Async1
 no ip address
 encapsulation slip
!
ip forward-protocol nd
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
!
!
!
!
!
!
control-plane
!
!
line con 0
line 1
 modem InOut
 stopbits 1
 speed 115200
 flowcontrol hardware
line aux 0
line vty 0 4
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 privilege level 15
 login local
 transport input telnet ssh
line vty 16
 privilege level 15
 login local
 transport input all
!
end

Commented:
where you installed SDM on yours pc or on router?

anyways ..it also looks urs router 1811 is not supported for SDM

http://www.cisco.com/en/US/products/sw/secursw/ps5318/prod_installation_guide09186a00803e4727.html#wp37069

Author

Commented:
Well crap, I guess this becomes a very different subject then... can you guys help me figure out why I can't ping this router that I am connected to? Even though the router can ping my PC? It's weird...

Commented:
do u have any acl running?

sh access-lists

Author

Commented:
Nope

Commented:
hmm its weird lol...can u ping any other ip from urs pc? if this correct than its not urs pc problem try restting router to factory default

http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_tech_note09186a00802017a1.shtml

Commented:
Don't know if this is a typo on your previous entry, but your VLAN1 interface is set to .110 and you are trying to ping .100!

If your PC was allocated an IP address from the router when you had it configured for DHCP then you have network connectivity to the 192.168.1.0/24 network.

Commented:
Also if you have changed the IP address of your PC manually make sure that you have the subnet mask set to 255.255.255.0

Commented:
Actually the whole 1800 series range of routers supports the SDM as per

http://www.cisco.com/en/US/prod/collateral/routers/ps5318/product_data_sheet0900aecd800fd118.html


Author

Commented:
Hah! Elvorfin, I think you made a typo when telling me to setup the VLAN1 as 110. I moved it to 100 (which makes sense to me now) and I got onto SDM just fine!!

Thank you guys so much... one last thing... does default-router command essentially define the IP for your 'default gateway' and then we excluded the address from the DHCP pool so that no one else took it to create a conflict? That is what I gathered.

Commented:
The default-router command sets the DHCP server to send that address as the gateway address to the client machines yes. It is setup in the exclusion list as it's the IP address of your router. Otherwise there would be a conflict if it got served out to a client device.

Have fun.