We help IT Professionals succeed at work.

Home Drive Mappings in Active Directory

Hello,

I created a new user, and everything is working well except for the Home drive that I mapped through Active Directory. Under the users profile in AD i specified to Connect H: to my file server \\SERVERNAMExx\home\jblow

I look on the file server and jblow is created. But when I log the user in, it doesnt map the drive. The login script I am using to map other drives works fine, just not the "Home Folder."

Am i doing something wrong?

Thanks!

Comment
Watch Question

Just out of curiosity are you using the %username% variable when you are trying to map the drive?

Does the user have access to the home folder? They will need access all the way down the tree to be able to reach their folder.

Author

Commented:
Hello,

 I am right clockng properties on the user in active directory. I go to the profile tab, and there is an option to create a home foler. I check the box  Connect H: to my file server \\SERVERNAMExx\home\jblow. It created this folder on my file server, but then when I actually log in the user, it doesnt map the H drive.

Is there something I am missing?  Unsure what you mean by  
%username%
can you try to disable all login script associated to the user, login as that user and let us know the result?
The %username% is a variable that can be used in AD for stuff like this. Basically you can do \\server\share\%username% and it will map the drive to their account.

As that user can you traverse the tree all the way down to their folder. Like can you start at \\servernamexx and then move through the folders until you get to their home dir. This could be a permissions issue.

The login script is also a good idea to make sure that nothing else is interfering with the mapping of the drive.

Author

Commented:
OK - so I dsabled the other login script and logged in again. No home drive.
I also checked the permissions to the jblow folder on my file server - this user has full control.

Puzzled. Shouldnt AD create the folder and set the permissions for me?
can you post the environment variables of this particular user?

this can be done by typing "set" on a command prompt.

you might also want to post the result of the following command:


NET USE H: /Home

Open in new window

Author

Commented:
User is running Windows 7. AD running on server 2003. File server is the same server as the AD server. The other logon scripts work ok - and maps my programs and my shared directories.

When running net use H: /home  I get

"system error 85 has occured.

The local device name is already in use"
You havent answered my question yet. You mentioned that the user has full control to their own folder.

What does the user have for permissions on the folders above that. If it cant read and traverse the folders above it will not be able to reach the users folder.

Author

Commented:
just running "net use" shows me my 2 other mappings just fine, but not H.
is H:\ mapped to something else previously?

Try goto Tools Menu > Disconnect Network Drive in Windows Explorer to verify.

You might have to disconnect manually and re-login again to see is h:\ mapped to home drive again.

Author

Commented:
Sorry - the folder above that is my Home folder that is shared out. "Everyone" has read and execute/list/read/write.

next folder down is jblow - and the user has full contol.
Try running

NET USE H: /d /y
That should delete any drive already mapped.

Author

Commented:
OK - disconnected all drives, logged off, and logged back on. Nothing.

Very weird. This has never happened before, even on Windows 7 machines.
does running
net use H: /home
works?

PS: would be helpful if you disable all login script, Group Preference, etc which can be used to map drives.
Ok windows 7 hmmmm out of curiousity is the network type specified as work.

Author

Commented:
Current profile is actually set up as DOMAIN and network sharing and dscovery is on.

HAve to run out now... sorry. I will check this posting again later.

Author

Commented:
These helped, but still never figured it out.