We help IT Professionals succeed at work.

Turn off Automatic Update?

Hi Experts,

I have a wins XP pro, my account is local admin and this PC is in AD domain. How do I turn off automatic update on this PC? Please take a look at the image.

Thanks.
untitled.JPG
Comment
Watch Question

Commented:
You would have to talk to your administrator for the permissions in the group policy have them disabled from any user being able to change those settings.
Top Expert 2013

Commented:
Take an RSoP report in GPMC of this box, or run gpresult /v.   This setting is probably coming down from a group policy linked at the Site, domain, or OU level (most likely not site)

Computer Configuration| Administrative Templates | Windows Components | Windows Update.

So you could filter it so it doesn't apply to this box or you can define new settings for this box via a GPO that takes precedence.

Thanks

Mike

Commented:
You might have a domain policy that is over riding that ...

Author

Commented:
I'm fine with the 'Automatic update' on but I don't like it to reboot after the update when I'm not there since I'm doing a lot of simulation on my machine. Every time the machine reboots then next day I have to re-do all the work again. I want to reboot it by my self instead.

Commented:
Still, you won't have any choice in what happens until your domain policy is set to exclude you..
SP2 or 3?

Author

Commented:
It's SP3.
Try adding this keyword to the registry to stop the auto restart:

Go to registry editor and navigate to the following registry key:
 
HKEY_LOCAL_MACHINE \Software\Policies \Microsoft\Windows \WindowsUpdate\AU
 
Change the "NoAutoRebootWithLoggedOnUsers" DWord value to the required number.
 
0 = False (Allow auto-reboot)
1 = True (Disallow auto-reboot)

If the DWord does not exist, add it to the key

Commented:
There is a reason for the auto install to make sure all systems are up to date, I have seen alot of users not updating their systems when they have the option so having them set to automatic results in less stress for the admin due to the amount of users etc.  The only systems i have download but do not install updates until I say is on the servers.  However flubbster has a solution that will probably work for the time being.

Commented:
Type services.msc on run then disable Automatic Update Service.Thanks