We help IT Professionals succeed at work.

filezilla ftp not working from within LAN

MeridianManagement
MeridianManagement asked
on
I am trying to ftp to filezilla server running on one computer w/ windows 7 from another computer that is windows 7.

On the filezilla computer, to test it, I pulled up the windows command line ftp and am able to successfully login.

On another computer in the LAN, I can ping the filezilla computer, but I can't run the same ftp test.

Everything is behind the router/firewall. I have also added filezilla server executable to be allowed on port 21 in the windows firewall.

I've never had trouble with such a simple issue before. Any suggestions getting ftp to work?
Comment
Watch Question

Are both machine configured the same? Have you tried running Filezilla as an admin on the machine in question?
Are you able to connect to ftp at all?

Verify that both computers are on the SAME SUBNET, and also, even if you allow port 21, FTP Server needs many more ports open to act in PASV (or Passive) mode (which most clients operate in so you have to have windows allow a broad port range and make sure that your filezilla server is configured to use the same port range.

Author

Commented:
themrrobert,

Actually I don't think I even chose a port. I just allowed filezilla server in the windows firewall. Yes, they're on the same subnet and same router.

Is there somewhere in windows 7 where I have to open specific ports?

Author

Commented:
It's strange, I can connect to filezilla server locally (127.0.0.1) but not on another computer. I've had this problem behind a firewall but not on the same lan...

Commented:
is the firewall on both windows 7 machines configured for port 21

Commented:
FTP operates on two modes: passive and active.
It only uses the TCP protocol.
All mentions to ports refer to TCP: command port (20) and data port(21)
Depending on whether FTP is active or passive, the data port is not always 20.

In ACTIVE mode the client uses an unprivileged port to connect to the server's port 21; the
server responds to the client on the client port adding one to it (port + 1).
The problem is that the client firewall will not know what is that (port + 1) and
the connection breaks because of the firewall.

So, that's why there is PASSIVE mode. The client starts the communication to the
server on two unprivileged ports. The server will communicate with the client on
the client's data port + 1.

So, the key is to understand that FTP uses two ports to communicate: a command
port to initiate the connection and a data port for data transfer

Commented:
Also allow port 20 (TCP) in windows firewall

Author

Commented:
First of all, the client pc has no FTP issues as it can connect to other FTP hosts outside of the network. Second, I don't see any way to choose what ports to open in windows 7 on the host machine, only that I can select the FTP server executable as allowed.

Commented:
I meant open port 20 on the computer running filezille.

http://www.thewindowsclub.com/how-to-configure-windows-7-firewall

Author

Commented:
Both machines run filezilla, one runs filezilla server and one runs filezilla client. I see no way in either machine to open ports in the windows 7 os

Commented:

Open a port in Windows  Firewall --just a few steps to be on your way.

http://windows.microsoft.com/en-us/windows-vista/open-a-port-in-windows-firewall

Commented:
The link on my previous post was more for WinVista -- these instructions are specific to Win7.

Open a port in Windows Firewall

If Windows Firewall is blocking a program and you want to allow that program to communicate through the firewall, you can usually do that by selecting the program in the list of allowed programs (also called the exceptions list) in Windows Firewall. To learn how to do this, see Allow a program to communicate through Windows Firewall.

However, if the program isn't listed, you might need to open a port. For example, to play a multiplayer game with friends online, you might need to open a port for the game so that the firewall allows the game information to reach your computer. A port stays open all the time, so be sure to close ports that you don't need open anymore.

Click to open Windows Firewall.

In the left pane, click Advanced settings.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

In the Windows Firewall with Advanced Security dialog box, in the left pane, click Inbound Rules, and then, in the right pane, click New Rule.

Follow the instructions in the New Inbound Rule wizard.