We help IT Professionals succeed at work.

Outlook 2010 keeps prompting for password sending SMTP via SBS2008 Exchange

pcspcs
pcspcs asked
on
We have an SBS 2008 server.  My desktop PC had Outlook 2007.  I have one account that I connect to as a regular Exchange connection.  Another have a secondary e-mail address with a different domain name that comes to another account on the server.  I access it via POP/SMTP.  This allows me to choose which account to send outgoing mail from. This is necessary since Exchange/Outlook still only allow sending from a single domain.

I just upgraded to Outlook 2010.  The Exchange account works fine.  For the secondary address, I can receive via POP3 just fine.  I cannot, however, send mail through that account.  It just keeps re-prompting for the password.

I have a laptop on the network with the exact same server settings for the POP/SMTP account and it works.  On the Outgoing Server tab I've selected "My outgoing server (SMTP) requires authentication" and "Use same settings as my incoming mail server".  It makes no difference if I select "log on using" and type in the username and password.

I have verified the settings between my laptop and desktop for this account and they appear to be the same for this account.  The only difference is on the 1st account, which is the Exchange connection.  The desktop is direct connect on network whereas the laptop is set for RPC over HTTP.  But that should be unrelated since it's not the 2nd account that uses POP/SMTP.

What could I be missing?
Comment
Watch Question

Steve AgnewSr. Systems Engineer

Commented:
I'm guessing that Outlook 2003 doesn't want to send a password without encryption to a windows server.. you are probably going to have to have some encryption turned on somewhere to get Outlook 2010 to be happy.. NTLM can be turned on to allow for encryption in your properties it may be called SPA.. it may also have to be enabled on the POP3 exchange server as well if it's not...

Commented:
Hi pcspcs,

Try these steps:

1. Go to Control Panel
2. Open Mail
3. Highlight your e-mail account and click on Change
4. Click on More Settings
5. Click on the Security Tab
6. Uncheck "ENCRYPT DATA BETWEEN MICROSOFT OUTLOOK AND MICROSOFT EXCHANGE"
7. Apply and OK.
8. Try to log into Outlook 2010 again

If this won';t works then refer this artical if you are using exchange server 2007
http://www.experts-exchange.com/articles/Software/Server_Software/Email_Servers/Exchange/Outlook-continually-prompting-for-username-and-password.html

Thanks,

AgentMIK

Author

Commented:
Some assistance on how to do any of this would be helpful.  I assume I have to find some STMP server settings in Exchange Manager on the SBS server, but I've not even found that.  I was easily able to find SMTP relay options on SBS2003, but not having much luck here on SBS2008/Exchange 2007.
Commented:
agentmik,

There is no security tab when I click more settings. The tabs are only General, Outgoing, Connection and Advanced.  

I think I found the solution though.  On the  Advanced tab, I decided to set the "use the following type of encrypted connection (SSL)" from "none" to "auto".  This now works.  Oddly, on my laptop with Outlook 2003 , it's set for "none" and works fine.  It seems that Outlook 2010 wants it set for "auto".  Oh well.  I'm happy now.  Thanks!

Commented:
Hey congrats!  

Commented:
Don't forget to give the points....Thanks & most welcome for the next time :)

Author

Commented:
Posting close request