We help IT Professionals succeed at work.

Exchange 2003 Mobile Admin Web Page Errors

whoam
whoam asked
on
In the mobile admin page, I can log in.   I can see the MOBILE DEVICE SETTINGS and go to the REMOTE WIPE section, but when I enter a user name I get an error.  See code for full error text.  

I haven't been on this page for some time, so I'm not sure when it broke.  Server gets regular updates.

Server Error in '/MobileAdmin' Application.
--------------------------------------------------------------------------------

Object reference not set to an instance of an object. 
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace: 


[NullReferenceException: Object reference not set to an instance of an object.]
   Microsoft.Exchange.AirSync.Admin.Mailbox.propFindRequest(String deviceUri) +376
   Microsoft.Exchange.AirSync.Admin.Mailbox.getDevices() +193
   Microsoft.Exchange.AirSync.Admin.Devices.refreshDevicesTable() +128
   Microsoft.Exchange.AirSync.Admin.Devices.Page_Load(Object sender, EventArgs e) +160
   System.Web.UI.Control.OnLoad(EventArgs e) +99
   System.Web.UI.Control.LoadRecursive() +50
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.3607; ASP.NET Version:2.0.50727.3082

Open in new window

Comment
Watch Question

Alan HardistyCo-Owner
Top Expert 2011

Commented:
What happens if you enter an email address instead?

Author

Commented:
user name or email address = same result.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Previous question with the same problem and a suggested solution of changing the version of the mobile admin tool:

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23607401.html

Author

Commented:
Same error.  I uninstalled it, did an IISreset, then installed the newly downloaded .exe

Author

Commented:
Un-checking REQUIRE SECURE CHANNEL (SSL) under edit secure communication of the Exadmin virtual directory under the default website fixes the issue, but I don't want to leave this unchecked.  Can anyone give me a way to fix the error and keep the ssl requirement?
Co-Owner
Top Expert 2011
Commented:

Author

Commented:
alanhardisty,

Your solution requires that the ExAdmin vdir not require ssl.  I've seen that mobile admin will work w/o ssl on ExAdmin, but would like to keep all requiring ssl.  That said, can you safely/securely run without SSL on ExAdmin vdir?
Alan HardistyCo-Owner
Top Expert 2011
Commented:
The exadmin folder is used for access to the Public Folders and does not require SSL to be enabled on it as it is never accessed directly externally, so you will be fine to deselect SSL and leave it unselected.

Author

Commented:
Alanhardisty's link to http://social.technet.microsoft.com/Forums/en-US/exchangesvrdeploy/thread/75c159f0-1024-4909-9f3c-6e935f3ed6cf is a very complete solution.  I found all I needed was to uncheck force SSL on the ExAdmin virtual directory.