We help IT Professionals succeed at work.

Active Sync won't work over 3G

I have windows mobile which doesn't sync over 3g but does over wifi.When on 3g I can browse internet on my mobile.I have rest the phone and its still the same.Any suggestions.
Comment
Watch Question

Distinguished Expert 2018

Commented:
Start with www.testexchangeconnectivy.com and see what it comes up with.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
What version of Exchange are you using?
Exchange 2007, and its working for everyone else except me and I am not an administrator.
Really weird I can sync through wifi its just when using 3G.Do known of any issues with windows mobile 7.0 or previous versions .It did work for couple of weeks and all of a sudden stopped working.
Only thing I can remember doing is when connecting the mobile to PC I have disabled the windows mobile network card on my PC and that when this started happening. I have reenabled it  connecting my mobile to PC.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Alan
I have already seen this article and at one of our clients site we had the same issue.But with in our company my account is a normal acocunt it isn't member of any of the default groups.I will any how check with our domain admin if he made any changes to my account.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Have you got the inherited permissions check box selected though?
Yeah thats what I did at the client site and its was exchange 2010 and the staff who had problems were members of the dafault AD groups(domain admins).
But with my case I need to wait till tuesday  for our domain admin to check the permissions.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - no problems.  Will wait to hear from you.
Enjoy the rest of the weekend.
Alan
Yeah, inherited permissions check box is ticked.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
What error code do you see on the device when trying to sync over 3G?
Support Code: 0x80072EE2
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Hmm - are you posting on another website too for the same question?
This is the only site that I have posted.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Okay - random, but I am working on a similar question with the same issues elsewhere!
Okay - what Phone is it and is the ROM up-to-date?
Do you have a website sitting at the same location as your Exchange server and can you browse that, not a /OWA or /EXCHANGE, but a www.yourdomain.com site?
Have you tried changing the DNS servers on the phone to different ones (like your ISP for your Internet connection at the office) and see if that makes it work?
Its HTC HD2
Its a brand new phone so I am guessing that the  ROM is up to date.
No we don't have any website hosted at ourr exchange server.
I can't find a way to change the DNS server on the phone.
Alan HardistyCo-Owner
Top Expert 2011
Commented:
Ah - new does not mean there isn't a new ROM.
Please visit http://www.htc.com/au/supportdownloadlist.aspx?p_id=297&act=sd&cat=2 and see if that is a new ROM for you.
Alan
Problem solved.
After setting up the active sync on the mobile just before clicking the finish, on the right hand side you have menu go to advanced and set the connection to dedicated.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Oh - a new extra step - how convenient.  and I was just about to look at my business partners phone to see if I could see anything useful!
Is your problem solved.
Strange connection revert backs to empty, and if you want to sync again you need to change the connection to internet.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
My problem?  In the other question?
Check out the ROM - there should be an upgrade that probably fixes a multitude of teething problems.
yeah, in the other question.
I will give it a try and,  let you know.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Not yet - still trying various things.
The phone seems to be working fine so I won't be upgrading ROM for now.Thanks for your help I am splitting the points between you and me.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Great news - glad it is still working.
I'm wrestling with the iPhone 4 / HTC HD2 - which phone to upgrade to shortly, so may have to refer back to this question for the final check box!
Have a great weekend.
Alan
All the best and have a great weekend.
Alan HardistyCo-Owner
Top Expert 2011

Commented:
Don't forget to close down the question.