We help IT Professionals succeed at work.

Windows Server 2008 Small Business Premium Install Issue

gocomptechny
gocomptechny asked
on
Hello, trying to fresh install (not migration install) SBS2008 premium on this server rig we custom built.  
If your very familiar with SBS2008 Install proceedures, the problem section starts below in CAPS saying " EXPANDING AND INSTALLING FILES "
Server has 2 seperate RAID arrays on 2 seperate RAID controllers.  Onboard Intel Matrix controller handing a RAID1 array of 2 Drives, this is also the raid array im installing my OS to.  The other array is the peripheral Highpoint Rocketraid 640 controller handling a 3 Drive RAID5 /w Hotspare.  Upon installation booting from CD Setup starts fine, am able to load my storage drivers for both controllers just fine and arrays show up, althought the Highpoint raid5 on the OS install screen doesn't show any available space, partition does seem to work fine tho as OS with installation errors present was working good enough to figure that part out.  Back to the DVD OS Install, Install gets through Copying files and the check list for loadiing files from DVD,  I am able to fill information, name, admin, domain etc.   The prompt for Test your network adapter screen i tried a couple different things hoping for a different outcome for the Install hang experienced shortly after these steps.  Installed driver through device manager for NIC only, disabled 2nd NIC present onboard, installed no others drivers at this point.  proceeded to select  Install with recommended setup updates, have also tried no updates for install.  Starts from what iv seen through examples on install the last batch of processing.  MOST IMPORTANTLY - The progress screen for  "EXPANDING AND INSTALLING FILES"  seems to start ok, PC restarts twice and then around 25% er so on the progress bar, at this position the PC will hang and although "Still Running" in task manager, install never completes.  Supposed to take 30 minutes, i left it overnight, no changes.  

Any Help would be great!
Comment
Watch Question

Commented:
Do you have a network cable plugged in? I had a similar problem and needed a cable plugged in, connected to a switch.

Commented:
Is this a purchased copy of a Microsoft DVD or is it a burnt version such as one downloaded from Technet? If it is a burned version, try reburing the dvd, you may have a bad disc.
Cris HannaSr IT Support Engineer

Commented:
Only 1 network adapter can be functional during install and it must be connected to the internet.
But we've also seen many many issues by choosing to "download and install updates" during the initial install.
My recommendation is do not update...then do the updates after the core system is up and running.
Distinguished Expert 2018
Commented:
I have seen Server 2008 (SBS and otherwise) be *far* more picky about hardware than any other version of windows. Even Server 2008 R2 is less picky. If thsi is a homebrew rig, as it sounds, I'm guessing you just have one of thsoe bad combinations and there really is no way around it. Try a different motherboard...the usual culprit.

The fact that you see no free space during the initial configuration...even if it *works*...is a big sign that sindows is already coughing on the hardware and not properly detecting your drive configuration.

Author

Commented:
This is server is technically a homebrew rig.  It is a server motherboard tho, tried to stay close to server based equipment for this reason,  The motherboard is a x8sti Supermicro server board, sporting a 2.26 Quad Core Xeon CPU, 6 Gb of ECC Corsair DDR3.  I have tried all of the above solutions and yes im aware that it still looks like hardware problem.

Any known issues?

Author

Commented:
Analysis was right on about hardware stopping installation