We help IT Professionals succeed at work.

Unable to acess file system of host from guest vmware image

opike
opike asked
on
I'm unable to access shared folders of the host (windows 7) from  a guest vmware image (also windows 7). However I am able to do file sharing the other way (host can access guest). Networking for the vmware guest is set up using NAT. The windows login is what fails; I try to login with the same account that I use to login to the host OS when it boots up.
Comment
Watch Question

Author

Commented:
I have a homegroup set up on the host OS. I tried using just the username and also <host>\username.
Since you are getting the authentication window, I doubt that your problem is with the firewall on the host. However, just to completely remove that variable, have you tried turning off your firewall on the host OS?

Another thing, and in order to isolate whether you're having problems with the VMware shared folders vs, problems with Windows sharing:

If you create a folder on your host OS, and give it the correct permissions, and try to access it from the guest OS, do you get the same authentication problem? or would it go through?
If it goes through, that means that there's something with the VMware shared folders. I'm assuming you're using VMware workstation? If so, what version? Personally, I have had some problems with shared folders in the past, so I wonder if your'e facing some of the same problems.

If the problem is in fact with the shared folders, try uninstalling and reinstalling the VMware tools, and see if that would help resolve the problem.

Disable Windows Firewall on both the Host and Guest.

Run this command from the Host

net use Z:/ \\<IP Address of the Guest>\C$

This should prompt for the User Credentials, entering the same should enable you to see the Guest VM's C Drive.

Author

Commented:
arun... the problem is connecting from the guest to the host. File sharing from host to guest already works fine.

Author

Commented:
I tried
net use Z:/\\192.168.122.209\C$
and received the error message:

System error 67 has occurred.

The network name cannot be found.

Author

Commented:
I verified that the firewall is disabled on both the guest and the host OS. I've attached a screenshot of the login prompt that I'm seeing when I attempt the file sharing.

WIN-D2SJSG6EMDD is the guest host name and Ollie-PC is the host. I tried logging in with the following usernames:

WIND-D2SJSG6EMDD\ollie
Ollie-PC\ollie (this is the one I thought should work)
ollie
login.jpeg

Author

Commented:
Duh...I must be working on too many things at once. The password wasn't enabled on the host machine for the account I was using.
Check whether you are able to telnet UDP Ports 137,138 and TCP Ports 139 and 445 from the Guest to Host.

telnet <IP Address of Host> 137
telnet <IP Address of Host> 138
telnet <IP Address of Host> 139
telnet <IP Address of Host> 445

You should get a blank window which confirms that these ports are open from Guest to Host, else there is something which is blocking the access.

What anti-virus are you running in the Host ?