We help IT Professionals succeed at work.

SecureCRT, WebHost Manager and Keys

I am trying to get public/private keys to work with SecureCRT and WebHost Manager, without success.

How anyone got this to work and, if so, what are the steps.

Thanks in advance.

Alan
Comment
Watch Question

SecureCRT

To create a public key with SecureCRT, hit the Tools menu, Create Public Key... option to begin the wizard.

Select RSA as the key type. Enter (or not) an appropriate passphrase to protect your private key. A default key length of 1024 is sufficient. Allow SecureCRT to save the key, noting the location thereof. It may ask if you want to use this as your global Public Key, and you can safely say "yes".

If you've done that and it's just not working, try this thread:

http://forums.vandyke.com/archive/index.php/t-923.html


This is what I used in the past to get it working.

Author

Commented:
Cuthbertx,

I guess I should have provided a bit more information.  My apologies.  I can create the keyfiles in SecureCRT, however, even following the instructions in the thread you posted I cannot export the keys from SecureCRT into WebHost Manager and get it to work.  I am getting an error that says:

Public_key authentication with the server for user xxxx failed.  Please verify username and public/private key pair.
Distinguished Expert 2019
Commented:
I think the public key can be accessed and uploaded:
http://www.vandyke.com/products/securecrt/public_key.html

Once you transfer the public key to the server, you need to add it into your login accounts home directory under .ssh/authorized_keys2.

Are you able to see the entry in its entirety in the file?  The key must be entered/added as a single line.  When you added it through the web manager, the string might have been broken into parts and would explain why it is not working.

Author

Commented:
arnold

Thanks!  I was saving the keys and adding to authorized_keys under root, not under the user.  I have root access disabled.  Your solution worked perfectly!

Alan