We help IT Professionals succeed at work.

SBS 2003 migration to SBS 2008 - Adprep returned: ConnectionError(4)  Skipping domain prep, since ADPrep failed.

I ran all the health checks before running the Source Server Migration Tool and getting

Adprep returned: ConnectionError(4)  Skipping domain prep, since ADPrep failed, the two other steps complete OK

ANy idea what is wrong? I have no AV and nothing fancy installed on the source server

Thank you
Comment
Watch Question

Distinguished Expert 2018

Commented:
Usually a connectionerror is pretty straightforward. Wasn't run as administrator so it couldn't bind to AD. A domain controller was offline. DNS server wasn't running. Try checking those things, rebooting the server, and rerunning.

Author

Commented:
I run it logged on as administrator, it's SBS so the box is the domain controller and I can authenticate, DNS server is running.

I ran the addprep /forestprep /wssg command manually and got this output

Adprep was unable to extend the schema.
[Status/Consequence]
The schema master did not complete a replication cycle after the last reboot. Th
e schema master must complete at least one replication cycle before the schema c
an be extended.
[User Action]
Verify that the schema master is connected to the network and can communicate wi
th other Active Directory Domain Controllers.  Use the Sites and Services snap-i
n to replicate between the schema operations master and at least one replication
 partner. After replication has succeeded, run adprep again.

well this is an SBS box so only one domain controller is allowed.

I went o Sites and Services and notice one of the member server listed there - very strange as they are not domain controller, I didn't run DCPROMO on the - it wouldn't work with SBS anyways

I'm unable to delete that object from there, it tells me to run DCPROMO on that server, but it's not possible as that server is not a domain controller so I'm in Catch 22 now

Author

Commented:
it also says if the domain controller is offline and no more available you have to delete them one at the time, but I can't
ok, I got it I had to first delete the NTDS object and then the top container - ran the prep tool and completed OK

Thank you
Distinguished Expert 2018

Commented:
SBS allows other domain controllers and if you have replication issues or if SBS thinks there is another DC when there isn't you need to clean that up.