We help IT Professionals succeed at work.

Incoming mail disappears and doesn't go to inbox in Outlook 2007 - Exchange 2003 Server

Hello,

This is very long story! Please be patient to read...

Scenario:
From past 2 years we are running Windows Server 2003 R2 x64 edition in our terminal server environment. Outlook 2007 is installed on Terminal Server. Exchange 2003 is running on dedicated server. All the installed software is up to date.

Problem:
In Outlook 2007, when receiving mail, emails disappear and doesn't go to the in-box. The view filters are set correctly. It seems to happen when emails are received from the same domain. It says 'receiving mail' but it just disappears. I mean it shows the 'incoming mail" pop up window but it didn't displayed in in-box or even in any folder! However everything works fine for remaining users. This only happens to one user. Previously I recreated his account and reconnected the exchange mailbox to new account. I enabled message tracking in Exchange Server and didn't found any issue!

From past 3 days we are getting some network problems due to some issues at our Internet Service provider, Verizon! I don't know whether this is causing these issues. Note that this is only happens to one particular user. And even that user can't connect to Outlook Web Access. When he tries to access his account using web, it shows some error messages.

Also I deleted the existing Exchange account and tied to create new Exchange account. But the automatic configuration is failed! i.e., the second task 'searching for username@domain.com' is failed. But I'm able to create the Exchange account in Outlook 2007 by entering manual details. i.e., exchange.domain.com and username@domain.com

Any further help would be greatly appreciated! Thanks.
Comment
Watch Question

Awarded 2009
Top Expert 2010
Commented:
Check your junk mail settings, they are probably set to delete mail rather than send it to the Junk Mail folder.

Goto Tools > Junk mail

Author

Commented:
Hi,

I fixed it! Under the View settings, I changed the Arrange By field from Size to Date. Anyway thanks for your tip which guide me to think about the custom settings in Outlook!
Awarded 2009
Top Expert 2010

Commented:
Good work :)

Author

Commented:
Changing the Arrange By field from Size to Date solves the issue.