We help IT Professionals succeed at work.

I set up a Windows 2008 Server with the Administrator login, but it does not have full permissions

edison04
edison04 asked
on
I set up a server/domain with Windows 2008 R2 Standard as Administrator, but now as I am trying to set up programs and move/delete files around and such, I keep running into "permission denied," and "you do not have access." In Active Directory, I am marked as Type "Users" and am a member of the Administrators group. I am not sure how to make this login a "real" administrator. I want it to be the Enterprise/Domain Admin with full-blown permissions.
Comment
Watch Question

Start -> Run -> dsa.msc

Find your username and add your username to Enterprise / Domain Admins Group which ca be found under Users OU
edison04Systems Analyst Sr.

Author

Commented:
I am already in those groups, but still get those errors.
You could try disabling User Account Control (UAC).   For some operations in Windows 2003 and 2008 Server, being in the admin group isn't good enough.  You need to actually log in as the Administrator.  Annoying I know, but it is what it is.  Disabling UAC should solve most if not all of these issues.

http://www.computerperformance.co.uk/Longhorn/server_2008_uac_user_account_control.htm#How_to_Disable_User_Account_Control_%28UAC
Lee W, MVPTechnology and Business Process Advisor
Most Valuable Expert 2013

Commented:
Do not disable UAC - it's there for a reason.  ESPECIALLY on a server.

Right click whatever you are trying to run and select "Run As Administrator"
edison04Systems Analyst Sr.

Author

Commented:
Thanks for the input; however, it is not the UAC popup I am getting. I am getting "permission denied--check with the Administrator"-type error messages. I thought I already WAS logged in as the Administrator--that's the login I am using. Is there a hidden Admin on a Server 2008? How do I get to it?
Lee W, MVPTechnology and Business Process Advisor
Most Valuable Expert 2013

Commented:
Check your security settings and take ownership of the file if necessary.
edison04Systems Analyst Sr.

Author

Commented:
It is not just one file. Like I said, it is as if I am not the Administrator.
Lee W, MVPTechnology and Business Process Advisor
Most Valuable Expert 2013

Commented:
So you don't want to check permissions then?

I understand you're annoyed... And if I didn't believe it was better to have to go through a little hassle, I would be more annoyed myself.  But the security config is there for a reason.  I don't know what happened on your system to prompt this... that's why we're looking at things.

Also, are you logged in as the "Administrator" account or an account with Administrator rights?  EVERYONE knows windows has an "Administrator" account and I've instances where microsoft specifically disables it's ability to do certain things as a security measure.  Create an admin account for yourself and put it in the domain admins group, then try.
edison04Systems Analyst Sr.

Author

Commented:
Actually, I am not annoyed--I am just trying to clarify my problem. I appreciate your patience.

I am not in front of the server right now, so I will have to try it tonight. But, I did check permissions many times. The account is the Administrator account that I first used when I took the server out of the box and loaded the operating system. Is there any way that guy would not be the actual Administrator? I am also puzzled that Administrator would be of the Type User in Active Directory instead of Type Administrator. It makes me think I have done something wrong.

I will try it from another created user in the Administrators group and see what happens tonight.

Thanks for your help.
Windows Vista and Windows 7 typically disable the Built-in Administrator account for Security reasons and the user has to manually navigate to secpol,msc to enable the built-in Administrator account.
I hope Windows Server 2008 has the same security restrictions as well and needs the user intervention to enable the built-in Administrator account.
I would like to correct my second statement as Windows Server 2008 requires the Administrator's password to be changed during first login.
edison04Systems Analyst Sr.

Author

Commented:
yes, it does. That is the account I am using.
Systems Analyst Sr.
Commented:
It turns out that I was working on a share and "Everyone" wasn't included in the Share access list. ONce I added everyone and used the Security to deny access instead I was okay.