We help IT Professionals succeed at work.

How can I  get Excel to display dates as month-day-year?

On one machine, my dates in Excel display as month-day-year, for example May 27, 2010 displays as 05/27/10.  (This machine is Windows XP, in case that's significant.  Excel 2003).

When I take that same file and open it on a different machine (Windows 7, also Excel 2003), the same date displays as 27/05/10.

Is this an Excel thing or a Windows thing?  How can I fix it so the date displays the way I want it, mm/dd/yy  ?

Thanks
Comment
Watch Question

Most Valuable Expert 2011
Awarded 2010
Commented:
Hello dwightbaer,

it's a Windows thing. You need to set the regional settings of the PC to US, This will have a default date format of mm/dd/yy.

cheers, teylyn
Most Valuable Expert 2013
Commented:
Excel defaults to the default regional setting, set through control panel, if you have that set to US region (or another region which uses mm/dd/yy) then you should get the date format you want.
Of course you could also change the format for just the worksheet in question
regards, barry
Expert of the Quarter 2010
Expert of the Year 2010
Commented:
The first image shows how you can set the formatting from Excel per Barry's comment.
The 2nd is where the setting is in Windows, Control Panel, Regional Settings.  As you can see I'm a kiwi (New Zealander) so it shows as dd/mm/yyyy from the British tradition
ee.PNG
ee2.PNG
Dwight BaerStudent

Author

Commented:
Hmmm...

1.  I changed the Regional settings to English (U.S.), then rebooted the machine and re-opened my spreadsheet.  The dates still showed up as 14/06/10  instead of 06/14/10

2.  I tried to re-format it using the Excel --> Format Cells --> Date --> 03/14/01.  No joy.

3.  Thanks for the graphic help, cyberkiwi.  I then tried to format it using a custom format - m/d/yyyy.  That worked.

Thank you very much, cyberkiwi, tevlyn and barryhoudini.