We help IT Professionals succeed at work.

I need SBS 2008 DNS configuration help!

chrisdodds
chrisdodds asked
on
I have a brand new Dell server with a factory fresh SBS 2k8 image.  I have run through the wizards and all is well on my server.  However, for some reason, I cannot access the internet on my network desktop machines.  DHCP and DNS are configured and running on the server.  I can access the internet from the server, and I can see my server from the desktop workstations so I know I have network connectivity.  An ipconfig /all on any workstation reveals that I am getting my IP address from the server and the DNS server is the SBS 2k8 server too.  However, I can't resolve http://connect to join my workstations to my domain, nor can i get them to the internet unless i manually change the DNS settings on the NIC of the workstations to point to DNS servers hosted by my ISP.  Any help?  I've done no tinkering or crazy goofy stuff, just using the MS wizards to configure this server.  I have setup DNS forwarder hopinf that would work, but no, not that either... HELP!
Comment
Watch Question

Commented:
on one of the workstations which has DNS pointing to the server can you enter nslookup using a dos window

when nslookup starts it should tell you what dns server it's using

then inside nslookup enter the name of your server to see if it resolves that
and also something like google.com

post what you get back here

Commented:
also go into the DNS server right click at the top left on your server name and bring up properties. In the interfaces tab check that it's listening on the servers IPv4 address and not just IPv6 or something like that.
Distinguished Expert 2018

Commented:
Post an ipconfig /all from client and server for starters, and we'll work our way from there.
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Brian PiercePhotographer
Awarded 2007
Top Expert 2008

Commented:
OK
First thing is that all machines, including the SBS server point to the IP address to the server as the ONE and ONLY DNS server. Set the TCP/IP settings and DHCP options to make sure this is the case.

To conect to the internet you need to set up a forwarder to point to an external DNS server, the wizard should have prompted ypu for this - you can run it again or use the info at http://www.petri.co.il/configure_dns_forwarding.htm
Hey guys.  I feel like an ass.  After struggling with this issue for almost an hour, I rebooted the server and everything was working like it's supposed to.  I was at my wit's end and it was getting late.  I've done several of these installs before with no hickups, but something was stuck in the craw.  Thanks for all your suggestions, but a reboot set me right.  The wizard's did what they were supposed to!