We help IT Professionals succeed at work.

Age of Empires III - Windows 7

cebasso
cebasso asked
on
Hello!!

I'm trying to play some older games (Age of Empires III, Command Conquer Generals, etc) over a lan with pcs running Windows 7 x64... but i really can't play since none computer can join a host game... nothing appears and neither direct connect!

I think its a IPX/SPX problem, because as i saw since Windows Vista, there is no support for it...

I saw in many forums the possibility to run the game using a Virtualization (Microsoft Virtual PC) but all pcs is running Windows 7 Home Premium x64 and its only supported by Windows 7 Ultimate, Professional

Somebody know how can i play multiplayer game without IPX/SPX in Windows 7... there is a way?

Some program? some solution?

Best Regards!
Carlos
Comment
Watch Question

You can't play Age of empires without IPX protocol , Generals works great with win 7 i play it myself.
for age of empires you could use vmware(www.vmware.com) and install win xp inside the virtual machine.
Regards.
Top Expert 2010

Commented:
Do you have connection i.e can you share files between your PC's?
This is mainly a connection problem otherwise the games should run just fine.
My sons played these games easily between W7 x32 and XP x32.
I will ask them tomorrow...
Just check if you all connect fine and that no firewall is blocking the
connection.Turn all firewalls completely off to check.
Most Valuable Expert 2013
Commented:
And you can create a virtual IPX LAN using Hamachi.
There's a useful add-on for AOE3 here to help with setup
http://aoe3.heavengames.com/downloads/showfile.php?fileid=2192 

Commented:
I would make sure that:
1. firewall has an exception rule for the games
2. Check routers that you are using and make sure the ports are forwarded if needed.
3. Have you tried running the game in compatability mode?
4. you can install virtual pc with no issues but the virtual xp that you can download will only run on win 7 pro or above so you will not be able to get that to work.

Just saw this:
http://www.microsoft.com/windows/compatibility/windows-7/en-us/Details.aspx?type=Software&p=Age%20Of%20Empires%20III&v=Microsoft&uid=&pf=0&pi=1&s=Age%20of%20empires%203&os=32-bit
apparently it is fine?

Author

Commented:
Hello,
All Windows Firewall is disabled, Public, Private, etc
Its a Wireless Router... Mikrotik RB411AH Wireless, the firewall is disabled... just bridge between the Radio and Link
All computers is comunicating, Ping, File Sharing...

When i try to Direct Connect, the game begin the connection but show after "The host canceled the game" and in the Room List, nothing appear
I tried to run in Compatibility Mode, but no success too...
Strange... but i think @Egycore is correct about IPX protocol, since all articles that i found on how to play Age of Empires III in Vista, is about how to install IPX/SPX on Windows Vista... but doesnt work for Seven
@MASQUERAID: i will try this way :D
Regards and thank you all for help!

Author

Commented:
@MASQUERAID

Work great!
The only problem is the ping... inside lan less than 20 ms... using Hamachi Network no less than 300 ms and max 3000 ms... average 1500 ms :/

lag :(
Most Valuable Expert 2013

Commented:
You might be able to host Hamchi locally and so avoid an Internet connection but I don't think it's a fix that's legal so couldn't provide any information here.

Author

Commented:
@MASQUERAID
wow, nice way... contact me at cebasso at gmail.com (Email/MSN) if possible :D
or give me some way to contact you hehe
Best Regards,
Carlos