We help IT Professionals succeed at work.

Insufficient Memory to complete the requested action

minniejp
minniejp asked
on
Hi,

I am running a windows 2003 std server with Exchange 2003 SP2 and recently I have been seeing errors in the log files on this server.  Below are the errors:

"An error occurred during the message tracking decode operation.  Error from file e:\fisp2\admin\src\libs\rpc\rwlog.cxx line: 517. <<0xc0070008- Not enough storage is available to process this command.>>

I'm getting a similar message when trying to track an email and to view the network card details.  Everything else is fine, no problems sending/receiving emails?

There is sufficient HD space and more than enough memory, with a dual core processor.

Thanks
I
Comment
Watch Question

Commented:
Check your virtual memory settings. And check OS service pack.
Regards,

Author

Commented:
The virtual memory is set to Initial Size (MB) 2046 Maximum size (MB) 4092

The OS is SP 2

Commented:
What about size of RAM and what is recommended size for virtual mem.?
it does not look like a physical memory depletion to me. Most probably the server is running out of either paged pool or non paged pool memory. These two resources are very limited on a 32 bit OS. The total virtual address space on a 32 bit address is 4 GB (this is irrespective of the amount of RAM or the size of the page file) The virtual address is in no way related to the RAM or Page file. The 4 GB virtual address space is divided into two equal chunks -- user mode and kernel mode address space. All the applications run in the user mode portion and the kernel mode resources like paged pool, non paged pool, System PTEs, system cache, the kernel etc. resides in the kernel address space.

Are you getting event ID 2020, 2019 or 333 in the system event logs?

Pull up the task manager and go to the performance tab, take a screenshot and post it here

As you have mentioned that its a Exchange server, most probably you have the /3GB switch in Boot.ini, if yes please ensure that the /USERVA=2970 is set in the C:\boot.ini file

Add the /Basevideo switch in C:\boot.ini to load the no frills video driver, this will save pool memory

Go to the following location in the registry and make sure that SystemPages value is set to 0, LargeSystemCache is set to 0
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

What is the value for PagedPoolSize set to?

Make sure that the SNP features are disabled for the NICs

Go to the following location in the registry and set EnableTCPChimney, EnableTCPA and EnableRSS is set to 0
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters

On the Netwwork connections in control panel, right click the NICs and go to properties, click on teh advanced tab and hit the configure button, you will see the features list on the left, disable anything where you see  "OFFLOADING" mentioned

Reboot the server after making all these changes and let me know how it goes

Thanks,

Author

Commented:
We currently have 4GB of RAM but I checked the document on "How to optimize memory usage in Exchange Server 2003" and it mentioned a error which would appear within event viewer, with the ID of 955, which I don't have.
It does not matter how much RAM you have the virtual address space will be 4 GB on a 32 bit OS -- its hard coded.
Pplease check the settings that I have mentioned. let me know if you see 2019, 333 or 2020 in the system event logs in the eventviewer.

Author

Commented:
no, I don't have any errors in the event log with those IDs.  I will do what you have mentioned above now.

Thanks
Shreedhar EtteTechnical Manager
Top Expert 2010

Commented:
Run Exchange 2003 Best Practise analyser and fix the errors reported.

Author

Commented:
I did all as suggested, rebooted the server and now no longer receiving the error above.  Thanks very much for your help!