We help IT Professionals succeed at work.

Exchange 2007 - Error encountered while trying to dismounting the database

TCLiven
TCLiven asked
on
Hello All -

Need a little advice on how to take care of this once and for all.  I have recently taken over the Exchange Admin role for our company and have had to perform a couple restores already.  Each time I try to dismount the last database I restored with Database Recovery Management, I receive the following error: "Error encountered while trying to dismounting the database (Mailbox Database - OpsMgmt) in the recovery storage group (Recovery Storage Group). Error message is: Failed to dismount (offline) database Exchange01\Recovery Storage Group\Mailbox Database - OpsMgmt.  Reason: Cluster Common Failure Exception: The cluster resource group for clustered mailbox server Exchange01 was not found."

Now if I bounce the server, all is well and I can dismount, this happens with mounting the database as well, it will not allow me to mount either unless I bounce the server and then everything works for the current procedure.  The problem with this, as you can guess, is I can not continually be bouncing my Exchange server and usually a restore will take almost a good full day since I have to schedule the bounce after business hours.  I would like to fix the problem for good.

Has anyone had this type of issue before and what did you do to fix it?  Since I am new to the Exchange world, I would greatly appreciate any advice on where to start with troubleshooting this problem, since google searches are not quite giving me what I am looking for.  Thank you for your help.
Comment
Watch Question

Author

Commented:
I want to add a little more info here... don't know if it will help with this issue however the drive that is designated for my recovery storage group is local to the primary node of the cluster, not on the san cluster and when I go into the exchange management console, the RSG database does not show up in the Database Management window.  I have tried the following via shell as well (the the primary node), with the same results: Dismount-Database -Identity "exchange01\recovery storage group\mailbox database - opsmgmt".
Can you see the store in Clus Admin if Exchange is on W2k3 or Failover Clustering if its on W2k8 ?
If you can see the RSG within the console in mounted / green signal. Please bring it offline, after unchecking the "affect this group" in its properties.

Author

Commented:
No, the local drive designated for RSG is not part of the cluster, so I can not see it in Clus Admin.

Commented:
Try running eseutil against to mailbox database. It may be corrupt in some spots.

Author

Commented:
How do I run eseutil against the mailbox database if it does not show up in the managment console?  Possibly a command line procedure, I'll take a snoop around and see if I can find that one out.

Commented:
Yes you run it through a command line.

Have a look here.

http://technet.microsoft.com/en-us/library/aa996773(EXCHG.65).aspx

Author

Commented:
Hi tcomp -
sorry for the delay in getting back to you.  I have a slight reservation on running this and maybe I am being way too cautious however, when I restored the database to the rsg, it was restored with the original database name.  So.. I have the production database "OpsMgmt", as well as the rsg database "OpsMgmt".  I want to run the utlity on the rsg database NOT the production database and I do not see an option for the rsg database or am I missing something.  Thanks for your help.
Have you checked the EMC Troubleshooting Assistant tool?

Also, when you run Get-MailboxDatabase - doesnt it show you the RSG Mailbox database in dismounted state.

Author

Commented:
Hi Exchange Geek -
No, it does not show it as dismounted since it is not.  The database will not dismount unless I bounce the server, once I bounce the server it dismounts fine.  Can I force it to dismount via the shell?
Yes you can,
http://www.msexchange.org/tutorials/Working-Recovery-Storage-Groups-Exchange-2007.html
this does not give you the commands for dismounting, however gives you methods to find your database using shell - of course you should be able to dismount it using hints in the article.