We help IT Professionals succeed at work.

Power Options not working in Windows 7

I had posted earlier to find out how best to set up a Laptop to use an external Monitor, Keyboard & Mouse, below.

Original Post

I have a new Notebook with Windows 7 Home Premium, a MSI A6200-038us.I have set up with an external LCD as well as a logitech cordless keyboard & mouse. I have set all the Power Options in Windows 7 to never turn off or sleep, basically always on. I have also turned off the Eco button on the keyboard to off. After around 20 to 30 minutes of non-use, the laptop powers down. I called MSI tech support and they were wholly useless, not even attempting to troubleshoot the problem, instead telling me to send the Notebook back in for repair.

Right now I'm waiting to find out if this also happens when the laptop is just on it's own, w/o the external stuff. Also, when I boot back up the Notebook, some icons that I have arranged in a certain part of the desktop have been relocated back to their original position. When starting up the laptop, it does NOT say that the laptop is recovering from any errors or did not shut down properly.

I can use the laptop for hours at a time without any issues, but once I step away from it for 30 minutes, it shuts itself down.

Notebook Manual

What is the best way to troubleshoot this? Will event viewer tell me anything?
I will not have access to this machine for a couple of hours....it belongs to a client.
Comment
Watch Question

Is there any sort of 3rd party power management software running? Have you checked the BIOS for anything weird?

When you set the power management options in Windows, did you just choose a prefab scheme or did you go to the advanced options?

Author

Commented:
No 3rd party power management software.
Have not checked the BIOS.....What exactly would count as weird?
I basically went into power options and turned each individual option for both battery and AC to Never Turn Off.
Ok, well its kind of confusing but in Windows 7, even when you have the stuff turned off in the main power options screen, if you click advanced, there's still a lot more things to turn on or off. For instance, I'm pretty sure the other day I  had sleep disabled on the main screen, but hibernation enabled on the advanced screen... and there was no way to see it unless I clicked the advanced button... so try looking there.

Author

Commented:
Meastro....I think you're right....was able to find the advanced options and set the Hard Drive & sleep to never. I just have to wait now & see if it works. Should I also change the USB settings to never to make sure that the logitech cordless keyboard & mouse will start right up when I move the mouse or press the keyboard??
sure, why not? if you've got the stuff plugged in, why do you want anything shutting off?