We help IT Professionals succeed at work.

Chkdsk reports unable to read security descriptors

A user reports the following with his personal laptop and is requesting my help:
"I was unable to boot the computer, so took out the hard drive and put it into a external SATA docking station. I have access to drive d: but drive c: looks pretty bad. I tried to run a chkdsk /f. It does a lot of stuff but at the end I get this “unable to read the security descriptors data stream” error. Do you have any suggestions what I can do to access this drive? My last backup is about 6 weeks old and it would really be good to have this data."
Is there any hope for the user to access the data? The best thing I could find on Google was this: http://www.pcbuyerbeware.co.uk/SoftwareProblems3.htm#chkdsk.
Comment
Watch Question

Most Valuable Expert 2015

Commented:
You can first try to run the HD manufacturer's diagnostic utility on it, some can repair certain errors, and then after it has repaired them, try chkdsk /x again. If it still doesn't finish, scan it using getdataback, and if that tool sees the data needed, register it and use it to copy the data from the bad disk. You'll find the manufacturer's tools on the UBCD, and below it is the link to getdataback:

http://ultimatebootcd.com
http://runtime.org
The user was able to recover data by running DiskInternals Partition Recovery 3.7.