We help IT Professionals succeed at work.

PIX 515 to ASA 5505 VPN tunnel problems...

medica1
medica1 asked
on
Howdy Experts,
I am having issues establishing a VPN tunnel between an ASA (vendor) and a PIX (me). Attached are obfuscated configs from both devices, as well as a "debug crypto isakmp" from the PIX.
I think I see the issue in the following lines of the debug, but everything I look up seems to point to an ACL not properly mirrored or PFS using the wrong group. Pretty sure we aren't using PFS, and the ACLs look good to me.

ISAKMP (0): atts not acceptable. Next payload is 0
ISAKMP (0): SA not acceptable!
ISAKMP (0): sending NOTIFY message 14 protocol 3
return status is IKMP_ERR_NO_RETRANS

Any assistance with this issue would be most appreciated!
Thanks,
JC
////////// SITE ONE CONFIG

PIX Version 6.2(2)
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password ASDFASDFASDF encrypted
passwd ASDFASDFASDF encrypted
hostname pixfirewall
fixup protocol ftp 21
fixup protocol http 80
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol sip 5060
fixup protocol skinny 2000
no names
access-list inbound permit icmp any any 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq www 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq pop3 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq ssh 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq ftp-data 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq 3389 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq 2300 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq smtp 
access-list inbound permit tcp any host [SiteOneOutsideIP] eq 3500 
access-list NoNAT permit ip 10.58.0.0 255.255.0.0 192.168.1.0 255.255.255.0 
access-list 87 permit ip 10.58.0.0 255.255.0.0 192.168.1.0 255.255.255.0 
pager lines 24
logging on
logging timestamp
logging buffered debugging
logging trap debugging
logging history debugging
logging host inside [SiteOneLogServer]
interface ethernet0 auto
interface ethernet1 auto
mtu outside 1500
mtu inside 1500
ip address outside [SiteOneOutsideIP] 255.255.255.224
ip address inside [SiteOneInsideInterface] 255.255.0.0
ip audit info action alarm
ip audit attack action alarm
ip local pool rmcippool 10.58.6.20-10.58.6.100
no failover
failover timeout 0:00:00
failover poll 15
failover ip address outside 0.0.0.0
failover ip address inside 0.0.0.0
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NoNAT
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp [SiteOneOutsideIP] www [SiteOneWebServer] www netmask 255.255.255.255 0 0 
static (inside,outside) tcp [SiteOneOutsideIP] pop3 [SiteOneMailServer] pop3 netmask 255.255.255.255 0 0 
static (inside,outside) tcp [SiteOneOutsideIP] smtp [SiteOneMailServer] smtp netmask 255.255.255.255 0 0 
static (inside,outside) tcp [SiteOneOutsideIP] ssh [SiteOneServer] ssh netmask 255.255.255.255 0 0 
static (inside,outside) tcp [SiteOneOutsideIP] ftp-data [SiteOneServer] ftp-data netmask 255.255.255.255 0 0 
static (inside,outside) tcp [SiteOneOutsideIP] 3389 [SiteOneServer] 3389 netmask 255.255.255.255 0 0 
static (inside,outside) tcp [SiteOneOutsideIP] 2300 [SiteOneServer] 2300 netmask 255.255.255.255 0 0 
static (inside,outside) tcp interface 3500 [SiteOneOtherWebServer] www netmask 255.255.255.255 0 0 
access-group inbound in interface outside
access-group outbound in interface inside
route outside 0.0.0.0 0.0.0.0 [SiteOneRouter] 1
route inside 10.0.0.0 255.0.0.0 [SiteOneGateway] 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
url-server (inside) vendor websense host [SiteOneWebsenseServer] timeout 5 protocol TCP version 1
filter url http 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow 
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
no sysopt route dnat
crypto ipsec transform-set strong-des esp-3des esp-sha-hmac 
crypto dynamic-map cisco 4 set transform-set strong-des
crypto map partner-map 22 ipsec-isakmp
crypto map partner-map 22 match address 87
crypto map partner-map 22 set peer [SiteTwoOutsideIP]
crypto map partner-map 22 set transform-set strong-des
crypto map partner-map client configuration address initiate
crypto map partner-map client configuration address respond
crypto map partner-map client authentication partnerauth
crypto map partner-map interface outside
isakmp enable outside
isakmp key ******** address [SiteTwoOutsideIP] netmask 255.255.255.255 no-xauth no-config-mode 
isakmp identity address
isakmp policy 8 authentication pre-share
isakmp policy 8 encryption 3des
isakmp policy 8 hash md5
isakmp policy 8 group 2
isakmp policy 8 lifetime 86400
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 11 authentication pre-share
isakmp policy 11 encryption 3des
isakmp policy 11 hash sha
isakmp policy 11 group 2
isakmp policy 11 lifetime 86400
telnet 10.58.0.0 255.255.0.0 inside
telnet timeout 30
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
terminal width 80
Cryptochecksum:1df6084afae594eabfca921ea73206dc




////////// SITE TWO CONFIG

ASA Version 8.0(3) 
!
hostname [SiteTwoHostname]
domain-name [SiteTwoHostname.com]
enable password ASDFASDFASDF encrypted
names
name [SiteOneOutsideIP] RMC
name 10.58.0.0 Meditech
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address [SiteTwoOutsideIP] 255.255.255.248 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd ASDFASDFASDF encrypted
boot system disk0:/asa803-k8.bin
ftp mode passive
dns domain-lookup outside
dns server-group DefaultDNS
 name-server [SiteTwoDNSPrimary]
 name-server [SiteTwoDNSSecondary]
 domain-name [SiteTwoHostname.com]
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 Meditech 255.255.0.0 
access-list outside_1_cryptomap extended permit ip 192.168.1.0 255.255.255.0 Meditech 255.255.0.0 
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool vpnpool 10.1.1.20-10.1.1.50
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-603.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
route outside 0.0.0.0 0.0.0.0 [SiteTwoRouterIP] 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
http 192.168.1.254 255.255.255.255 inside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac 
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac 
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac 
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac 
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac 
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac 
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac 
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac 
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs 
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set nat-t-disable
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs 
crypto map outside_map 1 set peer RMC 
crypto map outside_map 1 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable inside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 30
 authentication pre-share
 encryption 3des
 hash md5
 group 2
 lifetime 86400
telnet 192.168.1.254 255.255.255.255 inside
telnet 0.0.0.0 0.0.0.0 inside
telnet 192.168.1.0 255.255.255.0 inside
telnet 0.0.0.0 0.0.0.0 outside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns [SiteTwoDNSPrimary] [SiteTwoDNSSecondary]
dhcpd auto_config outside
!
dhcpd address 192.168.1.50-192.168.1.80 inside
dhcpd dns [SiteTwoDNSPrimary] [SiteTwoDNSSecondary] interface inside
dhcpd auto_config outside interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
username [SiteTwoUsername] password ASDFASDFASDF encrypted privilege 15
username [SiteTwoUsername] password ASDFASDFASDF encrypted privilege 15
tunnel-group TestGroup type remote-access
tunnel-group TestGroup general-attributes
 address-pool vpnpool
tunnel-group TestGroup ipsec-attributes
 pre-shared-key *
tunnel-group [SiteOneOutsideIP] type ipsec-l2l
tunnel-group [SiteOneOutsideIP] ipsec-attributes
 pre-shared-key *
tunnel-group-map default-group DefaultL2LGroup
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny  
  inspect sunrpc 
  inspect xdmcp 
  inspect sip  
  inspect netbios 
  inspect tftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:aaf0378603d435991586b9f676d0d611
: end
asdm image disk0:/asdm-603.bin
asdm location RMC 255.255.255.255 inside
asdm location Meditech 255.255.0.0 inside
no asdm history enable




////////// DEBUG CRYPTO ISAKMP FROM SITE ONE PIX

crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
VPN Peer: ISAKMP: Added new peer: ip:[SiteTwoOutsideIP] Total VPN Peers:6
VPN Peer: ISAKMP: Peer ip:[SiteTwoOutsideIP] Ref cnt incremented to:1 Total VPN Peers:6
OAK_MM exchange
ISAKMP (0): processing SA payload. message ID = 0

ISAKMP (0): Checking ISAKMP transform 1 against priority 8 policy
ISAKMP:      default group 2
ISAKMP:      encryption 3DES-CBC
ISAKMP:      hash SHA
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x1 0x51 0x80 
ISAKMP (0): atts are not acceptable. Next payload is 0
ISAKMP (0): Checking ISAKMP transform 1 against priority 10 policy
ISAKMP:      default group 2
ISAKMP:      encryption 3DES-CBC
ISAKMP:      hash SHA
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x1 0x51 0x80 
ISAKMP (0): atts are not acceptable. Next payload is 0
ISAKMP (0): Checking ISAKMP transform 1 against priority 11 policy
ISAKMP:      default group 2
ISAKMP:      encryption 3DES-CBC
ISAKMP:      hash SHA
ISAKMP:      auth pre-share
ISAKMP:      life type in seconds
ISAKMP:      life duration (VPI) of  0x0 0x1 0x51 0x80 
ISAKMP (0): atts are acceptable. Next payload is 0
ISAKMP (0): processing vendor id payload

ISAKMP (0): processing vendor id payload

ISAKMP (0): processing vendor id payload

ISAKMP (0): SA is doing pre-shared key authentication using id type ID_IPV4_ADDR
return status is IKMP_NO_ERROR
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
OAK_MM exchange
ISAKMP (0): processing KE payload. message ID = 0

ISAKMP (0): processing NONCE payload. message ID = 0

ISAKMP (0): processing vendor id payload

ISAKMP (0): processing vendor id payload

ISAKMP (0): received xauth v6 vendor id

ISAKMP (0): processing vendor id payload

ISAKMP (0): speaking to another IOS box!

ISAKMP (0): processing vendor id payload

ISAKMP (0): speaking to a VPN3000 concentrator

return status is IKMP_NO_ERROR
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
OAK_MM exchange
ISAKMP (0): processing ID payload. message ID = 0
ISAKMP (0): processing HASH payload. message ID = 0
ISAKMP (0): processing vendor id payload

ISAKMP (0): remote peer supports dead peer detection

ISAKMP (0): SA has been authenticated

ISAKMP (0): ID payload
next-payload : 8
type         : 1
protocol     : 17
port         : 500
length       : 8
ISAKMP (0): Total payload length: 12
return status is IKMP_NO_ERROR
ISAKMP (0): sending INITIAL_CONTACT notify
ISAKMP (0): sending NOTIFY message 24578 protocol 1
ISAKMP (0): sending INITIAL_CONTACT notify
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
ISAKMP: Created a peer node for [SiteTwoOutsideIP]
OAK_QM exchange
oakley_process_quick_mode:
OAK_QM_IDLE
ISAKMP (0): processing SA payload. message ID = 701994326

ISAKMP : Checking IPSec proposal 1

ISAKMP: transform 1, ESP_3DES
ISAKMP:   attributes in transform:
ISAKMP:      SA life type in seconds
ISAKMP:      SA life duration (basic) of 28800
ISAKMP:      SA life type in kilobytes
ISAKMP:      SA life duration (VPI) of  0x0 0x46 0x50 0x0 
ISAKMP:      encaps is 1
ISAKMP:      authenticator is HMAC-SHA
ISAKMP (0): atts are acceptable.
ISAKMP: IPSec policy invalidated proposal
ISAKMP : Checking IPSec proposal 2
ISAKMP: transform 1, ESP_3DES
ISAKMP:   attributes in transform:
ISAKMP:      SA life type in seconds
ISAKMP:      SA life duration (basic) of 28800
ISAKMP:      SA life type in kilobytes
ISAKMP:      SA life duration (VPI) of  0x0 0x46 0x50 0x0 
ISAKMP:      encaps is 1
ISAKMP:      authenticator is HMAC-MD5
ISAKMP (0): atts not acceptable. Next payload is 0
ISAKMP (0): SA not acceptable!
ISAKMP (0): sending NOTIFY message 14 protocol 3
return status is IKMP_ERR_NO_RETRANS
crypto_isakmp_process_block: src [UnrelatedVendorIP], dest [SiteOneOutsideIP]
ISAKMP (0): processing NOTIFY payload 36136 protocol 1
spi 0, message ID = 1822576450
ISAMKP (0): received DPD_R_U_THERE from peer [UnrelatedVendorIP]
ISAKMP (0): sending NOTIFY message 36137 protocol 1
return status is IKMP_NO_ERR_NO_TRANS
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
ISAKMP (0:0): phase 2 packet is a duplicate of a previous packet.
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
ISAKMP (0): processing NOTIFY payload 36136 protocol 1
spi 0, message ID = 3323598185
ISAMKP (0): received DPD_R_U_THERE from peer [SiteTwoOutsideIP]
ISAKMP (0): sending NOTIFY message 36137 protocol 1
return status is IKMP_NO_ERR_NO_TRANS
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
ISAKMP (0:0): phase 2 packet is a duplicate of a previous packet.
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
ISAKMP (0:0): phase 2 packet is a duplicate of a previous packet.
crypto_isakmp_process_block: src [UnrelatedVendorIP], dest [SiteOneOutsideIP]
ISAKMP (0): processing NOTIFY payload 36136 protocol 1
spi 0, message ID = 3218894644
ISAMKP (0): received DPD_R_U_THERE from peer [UnrelatedVendorIP]
ISAKMP (0): sending NOTIFY message 36137 protocol 1
return status is IKMP_NO_ERR_NO_TRANS
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
ISAKMP (0): processing NOTIFY payload 36136 protocol 1
spi 0, message ID = 3820619806
ISAMKP (0): received DPD_R_U_THERE from peer [SiteTwoOutsideIP]
ISAKMP (0): sending NOTIFY message 36137 protocol 1
return status is IKMP_NO_ERR_NO_TRANS
crypto_isakmp_process_block: src [SiteTwoOutsideIP], dest [SiteOneOutsideIP]
ISAKMP (0): processing DELETE payload. message ID = 1393864214
ISAKMP (0): deleting SA: src [SiteTwoOutsideIP], dst [SiteOneOutsideIP]
return status is IKMP_NO_ERR_NO_TRANS
ISADB: reaper checking SA 0x83c77360, conn_id = 0
ISADB: reaper checking SA 0x83c70ee8, conn_id = 0
ISADB: reaper checking SA 0x83c77b80, conn_id = 0
ISADB: reaper checking SA 0x83c79368, conn_id = 0
ISADB: reaper checking SA 0x83c719a0, conn_id = 0  DELETE IT!

VPN Peer: ISAKMP: Peer ip:[SiteTwoOutsideIP] Ref cnt decremented to:0 Total VPN Peers:6
VPN Peer: ISAKMP: Deleted peer: ip:[SiteTwoOutsideIP] Total VPN peers:5
ISADB: reaper checking SA 0x83c77360, conn_id = 0
ISADB: reaper checking SA 0x83c70ee8, conn_id = 0
ISADB: reaper checking SA 0x83c77b80, conn_id = 0
ISADB: reaper checking SA 0x83c79368, conn_id = 0
ISADB: reaper checking SA 0x83c92530, conn_id = 0

Open in new window

Comment
Watch Question

Commented:
It looks like you are using pfs on site one but not site two:

crypto map outside_map 1 set pfs

Author

Commented:
Ok, the vendor has disabled PFS on the ASA (Site 2), thanks for catching that muff. We are still unable to establish the tunnel. Debug crypto isakmp is now showing an error that while different, is very similar to the first error.

I might be way off base here, but it looks like the issue may now be the transform sets not matching.
The following line from the PIX debug crypto isakmp tells me that the PIX is looking for sha:
ISAKMP:      authenticator is HMAC-SHA
And the following line from the ASA config tells me that the ASA is looking for MD5:
crypto map outside_map 1 set transform-set ESP-3DES-MD5

Please correct me if my assumption is wrong. In the meantime, I think I will change my transform set on the PIX to MD5 and see what happens. I'll report my findings shortly.

////////// NEW "DEBUG CRYPTO ISAKMP" ERROR

ISAKMP : Checking IPSec proposal 1

ISAKMP: transform 1, ESP_3DES
ISAKMP:   attributes in transform:
ISAKMP:      SA life type in seconds
ISAKMP:      SA life duration (basic) of 28800
ISAKMP:      SA life type in kilobytes
ISAKMP:      SA life duration (VPI) of  0x0 0x46 0x50 0x0
ISAKMP:      encaps is 1
ISAKMP:      authenticator is HMAC-SHA
ISAKMP (0): atts are acceptable.
ISAKMP: IPSec policy invalidated proposal
ISAKMP (0): SA not acceptable!
ISAKMP (0): sending NOTIFY message 14 protocol 3
return status is IKMP_ERR_NO_RETRANS

Open in new window

Commented:
Yes, you are correct.

Author

Commented:
Thanks for the assist muff.