We help IT Professionals succeed at work.

How do I enable audio mapping over RDP on Windows 7?

djlurch
djlurch asked
on
I am connecting an XP Pro box to a Windows 7 Pro over Remote Desktop.

On the client side (XP) I have selected the "Bring Audio to this computer" option. I am able to play music via Winamp over the RDP connection, so I know that the audio chain is working.

What I want to is enable system sounds from the host (Windows 7) machine so that they come through to my client (XP) machine.

I googled and found this: http://www.visualwin.com/Audio-Mapping/. The problem is that there doesn't seem to be a tscc.msc (terminal services console) on windows 7. When I try to run it on the W7 box, it isn't finding anything. I know PC/Networking pretty well, but I'm new to Windows 7.

Can anyone help me get the audio from my host (W7) to my client (XP)?
Comment
Watch Question

Hi,
solution to your problem should be very simple. Instead of tscc.msc type mstsc into run box (or you can also type in into search box of start menu in Windows 7) and press enter.

Classic RPD menu will appear now go to Properties (sorry if my translation is bad I am using Slovak localisation of Win7) then Local resources and you should see Remote sound configuration menu.
expert.jpg
experrt-2.jpg

Author

Commented:
Commandosk:

Thank you for replying, but that is not at all what I am looking for. Please note that I am looking for the host settings, not the remote (client) settings.

Anyone else?
Justin OwensITIL Problem Manager

Commented:
So that I understand your question correctly, you are trying to connect TO a Windows 7 PC FROM and Windows XP PC (what SP and what version of RDP, please) and want to get the sounds which would normally be heard on the Windows 7 machine to play on the Windows XP machine?
Justin OwensITIL Problem Manager

Commented:
Also, what iteration of Windows 7?

Author

Commented:
Yes, that is what I am trying to do.

Client: XP Professional SP3 32 bit
Host: Windows 7 Professional 64 bit
Then my answer haven't changed, you just have to go into settings and set you want to transfer audio into your machine. just tried it like that on my two computers and everything works perfectly.
Justin OwensITIL Problem Manager

Commented:
Commandosk is correct.  There should be no setting necessary to set on the Windows 7 workstation.

Author

Commented:
I am able to hear sound via media players and via the sound configuration (theme) console (by clicking on the test button).

However, no sounds are made when (for example) a javascript alert pops up on the remote computer's browser.

Author

Commented:
PS: There is a setting for this in Windows 7. See the screenshot. However, changing the setting has not yet resolved the issue.
ee.gif
Justin OwensITIL Problem Manager

Commented:
OK, but if that setting is Enabled or Not Configured, it is the same.  The default behavior for that setting on a Windows 7 machine is to allow audio and video playback.  Remember that RDP will not pass all sound through, because it doesn't intercept the sound card itself, but some of the software that utilizes the sound card.  If your Java pop up does't utilize the Windows Media player, it will liklely not forward sound.  What mechanism does your Java app use to produce sound?
Commented:
Update:

I rebooted and re-connected to the host. This resolved the issue.

So the answer appears to be: use the "Group Policy Editor" to Navigate to: Computer Configuration -> Administrative Templates -> Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Device and Resource Redirect

There is a setting found here for "All audio and video playback redirect". Choosing "Enabled", applying, then reboot and reconnect.