We help IT Professionals succeed at work.

Digi PortServer TS 8/16 on SCO OpenServer 6 Spooler

Dan Kaib
Dan Kaib asked
on
Can anyone tell me how to configure a spooler in SCO OpenServer 6 for use with a Digi PortServer TS 8/16?

I configured a standard spooler to the port, it prints but is very slow.

I have never used a Digi PortServer with SCO.

Any help would be greatly appreciated.

TIA,
Dan
Comment
Watch Question

The best way is to use "realport".  That is a package from Digi that makes the TS look like a serial card installed in the machine.  Once it's set up with realport then you access the ports just like any other serial port.

http://www.digi.com/support/productdetl.jsp?pid=2247&osvid=110&tp=1&s=38&tp2=0

As for the speed issue;  What baud rate is the port/printer set for?  What kinf of printer?  What is the data stream (raw txt, PCL, PS...)?

Author

Commented:
Thanks for the reply mikelfritz,

I have the realport installed and setup using the same driver that is on the link you sent.

Currently those printers are connected to a Digi Concentrator and are printing fine.

The Digi PortServer ports are set the same for the printer 9600, 8, 1, N.  Most of the printers are Printek's.  The data stream would be raw txt.

I tried changing the altpin setting and the duplex setting on the PortServer but it did not matter.
I figured since it printed fine from the Digi Concentrator that the cabling would be the same for the Digi PortServer. Would that be true.

Dan
Yes, the pinout should be the same.  

So, the printers had the same settings (9600,8,1,n) whaen hooked to a concentrator and printer faster than with the TS?

Author

Commented:
The printers flew on concentrator.

On the PortServer it takes over a minute to print a half page.

My thought on the cabling is based on the concentrator cables are pigtails to an old molded MAI Basic Four serial cable.

I'm going to try running a cat5 cable directly from the PortServer to the printer with a 25-pin connector I have from another customer using a PortServer on AIX.
If the flow control is x-on/x-off then try using only transmit, recieve and ground on the modular connector.  Maybe the printer is toggling one of the hardware signals and the TS is listening.

I normally set it up as:
1 - black RJ pin 3
2 - green RJ pin 5
3 - red RJ pin 4
7- yellow RJ pin 6

Author

Commented:
Thanks mikelfritz.  Your first response was the correct answer.  The problem was I was not understanding what I was reading.  I considered Realport to be the package I installed not an option on the port.

I set the port profile to printer originally which caused my problem.
When I set the port profile to Realport all my printing problems were solved.

Thank you for all your help.
Dan
I'm glad it's all working...