We help IT Professionals succeed at work.

Windows Sharepoint Services 3.0 SP2 problem

I recently applied SP2 to WSS 3.0 and came across the problem that from what I can find has been pretty widespread.

I'm currently getting "Cannot connect to configuration database"

I have:

* Restarted Microsoft##SSEE service, W3C service and Sharepoint Service
* Rebooted the server (required to apply updates)
* Run "psconfig -cmd upgrade -inplace b2b -wait -force"
* Been through http://support.microsoft.com/kb/944154 which failed, see below:

<snip>
Performing configuration task 3 of 4
Upgrading SharePoint Products and Technologies...

Failed to upgrade SharePoint Products and Technologies.

An exception of type Microsoft.SharePoint.Upgrade.SPUpgradeException was thrown.
  Additional exception information: Upgrade completed with errors.  Review the u
pgrade.log file located in C:\Program Files\Common Files\Microsoft Shared\Web Se
rver Extensions\12\Logs\Upgrade.log.  The number of errors and warnings is liste
d at the end of the upgrade log file.

Total number of configuration settings run: 3
Total number of successful configuration settings: 2
Total number of unsuccessful configuration settings: 1
Successfully stopped the configuration of SharePoint Products and Technologies.
Configuration of SharePoint Products and Technologies failed.  Configuration mus
t be performed before you use SharePoint Products and Technologies.  For further
 details, see the diagnostic log located at C:\Program Files\Common Files\Micros
oft Shared\Web Server Extensions\12\LOGS\PSCDiagnostics_6_15_2010_11_1_53_312_19
65996320.log and the application event log.

C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>stsa
dm -o upgrade -inplace -url http://intranet

Database state cannot be changed while other users are using the database 'Share
Point_Config_3f2203a2-d36f-4784-86bf-bc80a30428c2'
ALTER DATABASE statement failed.
sp_dboption command failed.

* Checked DB permissions in Microsoft SQL Server Management Studio Express, Sharepoint_Config database seems to be inaccessible, see below.

===================================

The database SharePoint_Config_3f2203a2-d36f-4784-86bf-bc80a30428c2 is not accessible. (Microsoft.SqlServer.Express.ObjectExplorer)

------------------------------
Program Location:

   at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.DatabaseNavigableItem.GetChildren()
   at Microsoft.SqlServer.Management.UI.VSIntegration.ObjectExplorer.SummaryView.get_Items()
   at Microsoft.SqlServer.Management.UI.VSIntegration.AppIDPackage.ListViewVirtualStorage.CopyItems(ISummaryView summaryView)
   at Microsoft.SqlServer.Management.UI.VSIntegration.AppIDPackage.ListViewVirtualStorage..ctor(ISummaryView summaryView, List`1 columnDescriptors)
   at Microsoft.SqlServer.Management.UI.VSIntegration.AppIDPackage.RightPaneListViewer.PopulateView()

Event log shows the following, I know this can be a permission problem but since it doesn't mention the login details maybe something else?

SQL Database 'SharePoint_Config_3f2203a2-d36f-4784-86bf-bc80a30428c2' on SQL Server instance 'SERVER\Microsoft##SSEE' not found. Additional error information from SQL Server is included below.

Cannot open database "SharePoint_Config_3f2203a2-d36f-4784-86bf-bc80a30428c2" requested by the login. The login failed.

I also get the following but have had these for a while and they've never caused issues although getting a lot more of them at the moment especially when trying any operations on the databases.

The description for Event ID ( 17137 ) in Source ( MSSQL$MICROSOFT##SSEE ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: Lansweeper32.

I'm no database/Sharepoint guru so if anyone out there with more knowledge of this problem can point me in the right direction would be greatly appreciated.
Comment
Watch Question

Author

Commented:
Exert from PSCDiagnostics_6_15_2010_11_1_53_312_19
65996320.log:

An exception of type Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException was thrown.  Additional exception information: The initialize command is invalid or a failure has been encountered.
Failed to detect if this server is joined to a server farm.  Possible reasons for this failure could be that you no longer have the appropriate permissions to the server farm, the database server hosting the server farm is unresponsive, the configuration database is inaccessible or this server has been removed from the server farm.  To diagnose this problem further, review the extended error information located at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\LOGS\PSCDiagnostics_6_9_2010_22_37_25_546_2091076865.log.  If this problem persists, run this wizard again to disconnect from the server farm.  After disconnecting, run the wizard again to create or connect to an existing server farm.
Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException: Exception of type 'Microsoft.SharePoint.PostSetupConfiguration.PostSetupConfigurationTaskException' was thrown.

Again this seems to point to the config database.

I have also tried to run the Sharepoint Products and technologies Wizard but was forced to cancel it since it tried to restart iis and ended up freezing the inetinfo process which subsequently meant I had to kill and restart the process. As a cascade effect this kills the SMTP process.

If it's worth running it through (apparently it can fix a lot of issues) please suggest.

Lastly I have also tried to run the SQL BPA but was unable to connect to the MIcrosoft##SSEE database using the credentials.
Cris HannaSr IT Support Engineer

Commented:
Any failure of a monthly patch, Service Pack, etc is a free call to MS support
This issue has been a real pain.   I'd encourage you to work with MS Support to resolve it.
One of my customers spent 4 hours on the phone yesterday with MS Support

Author

Commented:
What's the best number to call Microsoft on for this kind of issue? Im afraid if I look for myself im going to end up being stuck in a transfer hell.
Cris HannaSr IT Support Engineer

Commented:
(800) 936-4900

Author

Commented:
Sorry I was after the Australian phone number.

I have tried checking the Microsoft site but it said my product ID was most likely an OEM so to contact them, they are just a whitebox provider and would be useless.

I did find some number which seems to be a support number but was on hold for 10 minutes and had to hang up as it cut into a meeting.

Will try again now and see how it goes.
Cris HannaSr IT Support Engineer

Commented:
I was unable to find a support number in Austrailia but I'll check with the Austrailian MVPs I'm sure they have it.

Author

Commented:
I managed to get through to Microsoft support but although I could hear them find they couldn't hear me so I had to hang up.

I have also tried Microsoft support online support (https://support.microsoft.com/oas/default.aspx?&gprid=3208&&st=1&wfxredirect=1) but because it's OEM Microsoft say to call your manufacturer, I have checked their site and they to say to call your reseller.

I have spoken to them and they suggested:

Removing the Service Pack (This SP cannot be removed)
Rolling back the database (Don't have current backup)
Calling Microsoft again (Which I will try now)
Sending all my notes to them to look at

Back on the technical front I'm currently getting my application log filled with:

SQL Database 'SharePoint_Config_3f2203a2-d36f-4784-86bf-bc80a30428c2' on SQL Server instance 'SERVER\Microsoft##SSEE' not found. Additional error information from SQL Server is included below.

Cannot open database "SharePoint_Config_3f2203a2-d36f-4784-86bf-bc80a30428c2" requested by the login. The login failed.

Author

Commented:
I have managed to get a hold of Microsoft and said that the decision of charging is up to the technician if the problem matches the KB article.

Since the current ID's im getting do not match it I decided to hold off and see if I can fix the problem with the Sharepoint config database first.

If I still have the problem after moving to 2008 R2 I'll re-consider contacting them.

Author

Commented:
I have backed up the content database (although it seems multiple exist using stsadm and a backupfull method seemed to get one in particular.

I have re-installed WSS 3.0 and reboot when I get a chance and see how it goes.
Commented:
Since I will be leaving this business soon I will have to abandon this question. I was planning to raise this with Microsoft when my other support incident were finished but will not get the time now.

Author

Commented:
See above.