We help IT Professionals succeed at work.

Excahgne 2010 Mapidelivery queue

Currently have Exchange 2007 which is working fine and we are in the final stages of testing exchange 2010, but can’t get past this intermittent issue of email randomly getting stuck in the mapidelivery queue. The mapidelivery queue will flush itself after exactly 30min but the next email that is delivered to the database will cause it to begin queuing emials again. This cycle of 30min will coninue until the Transport service is restarted. After the restart the mail will flow as normal and may continue to be fine fo days.

Primary Site Exchange 2010 is setup as follows two client access servers setup in a Client access array using NLB. 1 Hub Transport 1 Mailbox server (In DAG) and 1 Unified Comms Server

Secondary Site 1 Client Access\Hub Transport 1 Mailbox Server as the passive member of the DAG

All Hardware far exceeds minimum specs

All Hardware far exceeds minimum specs
Comment
Watch Question

Commented:
Have you checked your DNS . is it getting resolved ?
also you should run the ExBPA tool to analyze it .

Author

Commented:
DNS is all good, this only affects one database at a time.

Have run the ExBPA tool and no errors to report.
Commented:
after an extremely long support call with Microsoft this turned out being the fix

To disable TCP Chimney Offload, follow these steps:
a.      Use administrative credentials to open a command prompt.
b.      At the command prompt, type the following command, and then press ENTER:
netsh int tcp set global chimney=disabled


To disable RSS, follow these steps:
1.      Use administrative credentials to open a command prompt.
2.      At the command prompt, type the following command, and then press ENTER:
netsh int tcp set global rss=disabled

Information about the TCP Chimney Offload, Receive Side Scaling, and Network Direct Memory Access features in Windows Server 2008
http://support.microsoft.com/kb/951037