We help IT Professionals succeed at work.

cant send smtp tls port 587 with Thunderbird

I can’t send via SMTP TLS on port 587 with Thunderbird.
The same SMTP server on same TLS port 587 works on other email client like outlook express with the same configuration,  so I guess this is not a server issue.
The SMTP server is MS BPOS it that’s relevant.

Did anyone had this issue and can think of a way to resolve this?

Thanks
Comment
Watch Question

Edmond HawilaChief Operating Officer

Commented:
Did you try Outlook Express on the same pc or a different one?
Check firewall settings..
Also check to have the Latest version of Thunderbird just in case there was an issue with older versions or vice versa if you have the Latest try the previous one just in case they messed up something :)

Author

Commented:
it work on my windows with outlook Express.
the user with the issue is  running linux so outlook Express is not a solution for him.
we tried a few versions of  Thunderbird on his linux and on my windows - same error...
Thunderbird  shows it's connected  to the SMTP when sending but eventually gets timed out
FW is disabled.

Commented:
What kind of error it gives?
Try to enter username as an email-alias@domain.com instead of normal username.

Author

Commented:
im using email-alias@domain.com.
the error is time out in the connection
Commented:
Couple things to check.  In TB, Go to Edit-Preferences->Advanced->General and open the Config Editor and filter it to
timeout, and check the timeout options as below. You might have to modify them, but at least make sure they are set to those standards.

Then, go to Edit -> Account Settings and check and uncheck the various options there.  
You may have to test with various connection security.
TB-Timeout.JPG
TBGmailSMTPSecure.JPG

Author

Commented:
setting to STARTLS works great
Thanks!

Commented:
Glad to help.