We help IT Professionals succeed at work.

PFDAVAdmin Exchange 2007: 401 errors

AndrewHuges
AndrewHuges asked
on
Hi All,
Back in the Exchange 2003 days I used to use the PFDAVAdmin tool to assign everyone in our organisation reviewer permissions to each other’s calendar.  When I try to use the latest version of the tool (v2.8) to carry out the same task in Exchange 2007 I get the following error:

Could not connect to http://servername***************: The remote server returned an error: 401 (Unauthorized)

I’ve created a domain admin account and have assigned full access rights to my mailbox for this account by running the below command but when I run PFDAVAdmin with the account credentials specified in the shell command and attempt to browse my mailbox I still get the 401 error.

Get-Mailbox “MyUsername” | Add-MailboxPermission -User “UserAccount”-AccessRights FullAccess

Any ideas?

Thanks in advance
Andrew
Comment
Watch Question

Rajith EnchiparambilOffice 365 & Exchange Architect

Commented:
Is the account you are using a member of Exchange Organization Administrator?

Author

Commented:
Hi Rajith,
Yes the account is in the Exchange Organization Administrator group.

Thanks
Andrew

Author

Commented:
Looks promising gstoneEx, will take a look and get back to you.
Thanks
Andrew

Author

Commented:
gstoneEX,
The documenst are useful but I still get the issue with the 401 error. I must have to assign the account that I'm usign certain permissions to all mailboxes but am not sure what permissions are required.
Thanks
Andrew

Author

Commented:
Thanks Rajith, that explains the process nicely but I still get the 401 error when I try to browse into a mailbox.

Andrew

Commented:
Try give the PFDAVAdmin account a mailbox or use an account that has a mailbox itself.

Author

Commented:
MeganUK3,
I've tried using my user credentails, I am a  domain admin and a member of the Exchange Organization Administrator group and I have a mailbox yet I still get the 401 error (even when i try to use PFDAVAdmin browse into my own mailbox)
Andrew

Commented:
How are you specifying the server in PFDAVAdmin (server name or IP address)? If by name try IP. What are the results?

Author

Commented:
I've tried both server name & IP address, get the sam reaults with both.
I've just finally fixed this issue!
By simply opening PFDAVadmin, clicking on File, Connect and removing the option to 'Authenticate as currently logged-on user' then manually imputing my password the 401 errors were no longer present. These were, however, replaced with 500 errors. After a bit of digging around on the mailbox cluster (Server 2008) I realised that .NET wasn't installed as a role so installed and can no browse all mailboxes and public folder using PFDAVadmin.
Thanks foy your help with this guys.
Andrew

Commented:
Thanks for the update