We help IT Professionals succeed at work.

Cisco QOS to prioritize voice

e2346437
e2346437 asked
on
Hello,
I need some assistance applying QOS to voice on some MPLS VLAN links.  The WAN links transport SIP between sites.  The LAN transports SIP to only one device at each site (an NEC hybrid PBX).  Routers are Cisco 2800 and 1800 series, switches are Cisco 3600 series.

Here is one of my configs with some QOS commands that my NEC installer asked me to put in place.  I don't know Cisco QOS commands at all, so I have no idea if they are correct.

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CAR_ROUTER1
!
boot-start-marker
boot system flash:c2800nm-spservicesk9-mz.124-12c.bin
boot-end-marker
!
card type t1 0 0
logging buffered 51200 warnings
enable password xxxxx
!
no aaa new-model
no network-clock-participate wic 0
!
!
ip cef
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 secret 5 $1$dLcB$fcKqgHJOzrRmi26DArDuq0
!
!
controller T1 0/0/0
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-24
 description Point-to-point T1 to Presque Isle
!
controller T1 0/0/1
 framing esf
 clock source internal
 linecode b8zs
 channel-group 0 timeslots 1-24
 description Point-to-point T1 to Houlton
!
class-map match-all VOICE-TRAFFIC
 match ip dscp ef
!
!
policy-map VOICE
 class VOICE-TRAFFIC
  set ip dscp ef
  priority 600
!
!
!
!
interface FastEthernet0/0
 description Connected to MPLS Circuit
 no ip address
 duplex full
 speed 100
 service-policy output VOICE
!
interface FastEthernet0/0.392
 description Presque Isle MPLS VLAN
 encapsulation dot1Q 392
 ip address 10.0.0.1 255.255.255.252
!
interface FastEthernet0/0.393
 description Houlton MPLS VLAN
 encapsulation dot1Q 393
 ip address 10.0.0.5 255.255.255.252
!
interface FastEthernet0/1
 description Connected to Caribou LAN via CAR_SWITCH1 FastEthernet0/24
 ip address 192.168.0.1 255.255.255.192
 duplex full
 speed 100
!
interface Serial0/0/0:0
 description Presque Isle T1
 ip address 192.168.0.130 255.255.255.252
 shutdown
 service-policy output VOICE
!
interface Serial0/0/1:0
 description Houlton T1
 ip address 192.168.3.1 255.255.255.252
 service-policy output VOICE
!
ip route 0.0.0.0 0.0.0.0 192.168.0.10
ip route 192.168.0.64 255.255.255.192 FastEthernet0/0.392
ip route 192.168.4.0 255.255.255.0 FastEthernet0/0.393
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
line vty 5 15
 access-class 23 in
 privilege level 15
 login local
 transport input telnet
!
scheduler allocate 20000 1000
!
end
Comment
Watch Question

Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
Hi,

how much is the MPLS bandwith?

Author

Commented:
3 megabits on each remote office link, 6 megabits to the main.

Commented:
The marking that will be required is going to be somewhat determined by what your MPLS carrier supports.  

Have you contracted with the MPLS carrier for multiple class of service options?

If so, they should be able to provide you what marking they are expecting to see from your device to provide the service level associated with each class.

If you can get that we can take a look at what you have in place and determine if it will work, and if not what will be required to ensure the VoIP traffic is properly mapped to a supported CoS on the MPLS network.

Author

Commented:
The carrier does not support any MPLS marking whatsoever.  They call their product "MPLS" but it seems much more like "Metro Ethernet" to me.  The Adtran boxes they installed at each location fall under Adtran's Metro Ethernet line of products even.

Any QOS that is to be done needs to be done within my equipment.

Commented:
So really its a best effort service, ok, well QoS will at least protect you from queue drops.  Though I typically set the output queue high and skip the complexity of formal QoS configurations if the carrier can't honor the marking...

Given the bandwidth you have I'd almost say go with what you have and see how it works.  If you run into problems then take a deeper look at custom queueing to ensure your VoIP data isn't thrown in favor of bulk data.  

At 3Mb/s serialization delay is trivial, so working out a QoS strategy based on potetial delay is probably not worth the effort.  The only possible issue is starvation when you have a lot headed out the door.  If these links are regularly loaded heavy, say so and we can work out a queueing configuration.

Otherwise let it run and see how it works... If its not broken, don't fix it...

Author

Commented:
Gelgin,
Thanks for your reply.

I should have mentioned that it is broken and the voice quality is poor site-to-site.  The customer reports choppiness and static.

The customers' POS application runs over telnet, so that doesn't take much bandwidth, but Internet access to the remote locations goes over the same pipes so there is certainly a potential for a client PC to abuse the link.

If you can suggest the QOS commands I need I sure would appreciate it.

Commented:
Ok, I'll work something up... it will take me a bit as this is not my forte, and I'll want to test it in sim before I post a solution.  Don't want to make your situation worse.

Author

Commented:
I'm grateful for the assistance Gelgin but the situation is getting worse and I'm going to need a solution pretty soon.  If anyone else has a suggestion please let me know.
Istvan KalmarHead of IT Security Division
Top Expert 2010

Commented:
HI,

the config seems to be good, only you need to add bandwith command those interfaces which applied qos'

for example
int ser 0/1
 bandwith 64000

Commented:
Sadly we are in the middle of SAS hell, so I'm a bit buried, here are the references I'm using to do the research;

The Docs detailed but may be too much;

http://www.cisco.com/en/US/docs/ios/qos/configuration/guide/12_4/qos_12_4_book.html


The link below looks promising, but I haven't used it myself so use at your own risk.,..

http://www.zdnetasia.com/configure-qos-on-your-cisco-router-with-this-template-61974078.htm

Until I can work up something specific review the above to see if you can sort it out...

Commented:
More appropriately me or any of the fine experts on this site :)

Author

Commented:
Hi,
I haven't gotten any comments in more than a month.  Can anyone help?
Head of IT Security Division
Top Expert 2010
Commented:
you need:

interface FastEthernet0/0
 bandwith 9000000

3+6M MPLS