We help IT Professionals succeed at work.

need to open ports on my pix 501

MarcZabik
MarcZabik asked
on
tcp 3062 3063 3064 coming in
upd 3060 3061 going out

What would be the correct command line to enable this without conflicting with my current configuration?
Comment
Watch Question

Author

Commented:
Please help

Commented:
please post your current configuration

Author

Commented:

Here is my config, I would prefer by pdm, lasttime I did, can't remove the last translation rule I made...

User Access Verification

Password:
Type help or '?' for a list of available commands.
lavaltriepix> enable
Password: ********
lavaltriepix# show config
: Saved
: Written by enable_15 at 00:05:43.951 UTC Fri Jan 1 1993
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password JVoQ8NvFe9dVEbQP encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname lavaltriepix
domain-name trio-tech
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.0.0 Montreal_net
access-list inside_outbound_nat0_acl permit ip any Montreal_net 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any 192.168.1.192 255.255.255.192

access-list outside_cryptomap_20 permit ip any Montreal_net 255.255.255.0
access-list outside_cryptomap_dyn_20 permit ip any 192.168.1.192 255.255.255.192

access-list acl-out permit gre any host 207.96.179.124
access-list acl-out permit tcp any host 207.96.179.124 eq pptp
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 207.96.179.124 255.255.255.0
ip address inside 192.168.1.254 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool Lavaltrie_pool 192.168.1.201-192.168.1.235
pdm location Montreal_net 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 207.96.179.1 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 match address outside_cryptomap_dyn_20
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer 69.159.242.244
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ******** address 69.159.242.244 netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup lavaltrie_vpn_user address-pool Lavaltrie_pool
vpngroup lavaltrie_vpn_user dns-server 192.168.1.100
vpngroup lavaltrie_vpn_user wins-server 192.168.1.100
vpngroup lavaltrie_vpn_user default-domain lavaltrie.triotech
vpngroup lavaltrie_vpn_user idle-time 1800
vpngroup lavaltrie_vpn_user password ********
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 15
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 client configuration address local Lavaltrie_pool
vpdn group 1 pptp echo 60
vpdn enable outside
terminal width 80
Is there a specific IP you want the incoming traffic going to? You'll need a static if you want someone from the outside to initiate a connection over ports 3062 3063 3064.

Can you expand on what exactly you want to do?

Commented:
I assume you want to forward from the OUTSIDE ip address to an INSIDE host ip 192.168.1.9
For Inbound, you'll need to do this:
static (inside,outside) tcp 207.96.179.124 3062 192.168.1.9 3062 netmask 255.255.255.255 0 0
static (inside,outside) tcp 207.96.179.124 3063 192.168.1.9 3063 netmask 255.255.255.255 0 0
static (inside,outside) tcp 207.96.179.124 3064 192.168.1.9 3064 netmask 255.255.255.255 0 0
access-list acl-out permit tcp any host 207.96.179.124 eq 3062
access-list acl-out permit tcp any host 207.96.179.124 eq 3063
access-list acl-out permit tcp any host 207.96.179.124 eq 3064



Commented:
by the way, the acl-out is really in inbound access list since it's applied to the outside interface.  Not that it matters.

As far as letting the UDP ports mentioned above out, you don't need to do anything.  You don't have an access-list applied to the inside interface so any traffic will flow out since there is no access-group command.  If you want to restrict outbound, you'll need to create a separate access-list (for instance called "inside_out"):
(config)# access-list inside_out permit tcp any any
(config)# access-list inside_out permit icmp any any
(config)# access-list inside_out permit udp any any eq 3060
(config)# access-list inside_out permit udp any any eq 3061
(config)# access-group inside_out in interface inside


That will allow any TCP, any ICMP, any only 3060 and 3061 UDP

Author

Commented:
rehamris:

Thank you, I am sure this will help tremendously, why IP address 192.168.1.9 ? what if I want to unlock these ports for any internal IP?

I have this on server 2003, 2 network cards : ip from server to pix 192.168.1.250

ip for card local network : 192.168.1.101

I am installing a new alarm system and the alarm system needs to communicate from these ports, it will probably be attribuated an address with the server dhcp, so I would prefer the ports to be open for any internal ip. I already have open the ports in the server.


Author

Commented:
rehamris:

Thank you, I am sure this will help tremendously, why IP address 192.168.1.9 ? what if I want to unlock these ports for any internal IP?

I have this on server 2003, 2 network cards : ip from server to pix 192.168.1.250

ip for card local network : 192.168.1.101

I am installing a new alarm system and the alarm system needs to communicate from these ports, it will probably be attribuated an address with the server dhcp, so I would prefer the ports to be open for any internal ip. I already have open the ports in the server.


Thank you, your help is much appreciated!

Commented:
I just used 192.168.1.9 as an example.  

The inbound ports are forwarded from the outside interface of the PIX to an inside host.  If you want to forward the tcp/3062 - tcp/3064 ports to 192.168.1.250, change the static command above to this:
static (inside,outside) tcp 207.96.179.124 3062 192.168.1.250 3062 netmask 255.255.255.255 0 0
static (inside,outside) tcp 207.96.179.124 3063 192.168.1.250 3063 netmask 255.255.255.255 0 0
static (inside,outside) tcp 207.96.179.124 3064 192.168.1.250 3064 netmask 255.255.255.255 0 0
Leave the other commands the same as above.

You need to ensure that the alarm system device(s) have static IP Addresses or persistent DHCP reservations.  It is not recommended to forward inbound ports to random addresses and is very difficult to manage and maintain.

Author

Commented:
Thank you very much, I really appreciate your help, I was desperate!