We help IT Professionals succeed at work.

Google Analytics Report For A Group of Pages

azlumiere
azlumiere asked
on
Hi Gurus,

I'm having issues. This seems like it should be an easy task, but I just can't seem to get it to work right. I'm trying to create some custom reports in Google Analytics. I need to be able to create a report for individual advertisers that reports their banner clicks and any articles that they've written. I set the banners up with click tracking. Here's a scenario:

Advertiser 1: Here's what I'd like the report to include:

/ad-tracking-250/category1/single/advertiser1_com

/ad-tracking-728/home/advertiser1_com

/category2/an-article-advertiser1-has-written/

/category3/another-article-with-a-completely-different-name/

/category4/yet-something-different/

I found a similar question here:  http://www.google.com/support/forum/p/Google+Analytics/thread?tid=7d5718221966bf8e&hl=en  but this answer didn't seem to be specific enough to help me.

Here's what I've tried.

1. Go to Top Content View. Get these results:
404 pages were viewed a total of 12,334 times

Use the advanced filter under the results to try to pull content "containing":

/ad-tracking-250/category1/single/advertiser1_com | /ad-tracking-728/home/advertiser1_com |
/category2/an-article-advertiser1-has-written/ | /category3/another-article-with-a-completely-different-name/

I get this error:  0 pages were viewed a total of 0 times

2. I tried creating an Advance segment setting the Dimension to "Page" and then setting the "Condition" as "Matches Exactly" and then creating a new line for each URL I want to report. This seems to work pretty well-and shows results when I test the segment.

However, when I close out of the advanced segment and go back to Top Content, for example, and then choose the Advanced Segment and apply it, Analytics tells me:

237 pages were viewed a total of 9,280 times in the "Advertiser1" segment  

Obviously, I did not set the segment to match 237 pages. I only set the segment for 5 pages. So, it still seems to report hundreds of other pages that I don't want to report.

I must be missing something here, but I guess I've been looking at things for too long, and can't seem to figure out the problem. Does anyone have any idea what I'm doing wrong?

I'd really appreciate some thoughts!
Comment
Watch Question

Author

Commented:
Hhhmmm. No one has any thoughts on this? I've increased the point value if that makes any difference.
I think I figured out the problem with the Advanced Filter, at least. You can't put any spaces between the titles and the pipe "|". I guess Google reads the space as part of the actual title, and since this doesn't match any titles, the results are 0.

Still not sure how to get the Advanced Segments to work, but I guess this "solution" will have to suffice.