We help IT Professionals succeed at work.

MSL4048 Connection Error / Drive Error

radu580
radu580 asked
on
Hello,

Recently the  tape library MSL4048 was unable to make regular backups on the LTO4 tapes, returning different errors on the Symantec Backup Exec ("The drive hardware is offline"; "The driver detected a controller error on \Device\RaidPort1"; "the Device, \Device\Ide\IdePort0, did not respond within timeout period") and on the Control Panel from the MSL4048 (" Exception FB 1 -  Error", "Drive logged out  Code: FB 02").

Please take a look also to the attached logs.

I am using Symantec Backup Exec 12.5, Service Pack 3 as a Backup Server installed in HP  AIO1200r , Windows Storage OS and the server is SAS connected to MSL 4048 Tape Libray, 2 drives 1840,  LTO4.

The backup was working well until 3 days ago when it started to issue this errors. Do you have any idea of how to solve this problem?

Thank you very much! MSL4048-error.txt
Comment
Watch Question

Top Expert 2014

Commented:
I presume you're using the P800 rather than a dedicated controller, there are all sorts of weird problems using a tape on a P800, see http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&taskId=110&prodSeriesId=330755&prodTypeId=12169&objectID=c01856482 for example. Also http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?objectID=c00860678&lang=en&cc=us&taskId=101&prodSeriesId=3239093&prodTypeId=12169 - use the port that doesn't go through an expander.

Even better put a dedicated card in the server for it, I'd use a SC08Ge.

Author

Commented:
Library Information:
Serial Number                                        DEC832085G
Product ID                                                MSL G3 Series
Currently Installed Library Firmware        6.90 / 2.70e
Bootcode Firmware Revision                  0.60
Library Mode                                                Automatic, Sequential Autoload


Drive Information                                    1
Vendor ID                                               HP
Product ID                                               Ultrium 4-SCSI
Serial Number                                         HU18302R2F
Firmware Revision                                       U28W
Physical Drive Slot Number                       1
Element Address                                       1
Library LUN Hosted By Drive                 No
Data Compression                                      Yes
Interface Type                                         SAS

Drive Information                                      2 (Offline)
Vendor ID                                              HP
Product ID                                              Ultrium 4-SCSI
Serial Number                                        HU18302R2D
Firmware Revision                                  U28W
Physical Drive Slot Number                        2
Element Address                                       2
Library LUN Hosted By Drive                 Yes
Data Compression                                       Yes
Interface Type       SAS

The Server has LSI Adapter, SAS 300 series, 8 port with 1068E -StarPort  and Smart Array P800 Controller. I realized now that the "Medium Changer" is not listed anymore in Windows Device Manager, only "SCSIChanger".

Top Expert 2014

Commented:
<edium changer is probably missing because it's in sequential mode rather than library mode.

Author

Commented:
What do you mean by "sequential mode rather than library mode."?

Sequential mode is  an option of the library mode...

Library Mode       :  Random     Sequential   Automatic
                           Autoload    Loop

Now is on the Automatic; Autoload
Top Expert 2014

Commented:
Random is the normal mode for a library, means SCSI commands are sent to the changer to put tapes in and take them out; sequential it acts as if it was one enormous tape swapping one out for the next when first tape is full . Not sure how automatic works but really it should be in random mode.

Author

Commented:
I have tried also with Random, but still note made a difference.

 Anyway the problem seems to be somewhere on the connection of one of the drive to the tape library. Even after restarting the tape library the top mentioned errors occurs after notifying in the Panel that is connecting the drive.

This errors persists even if the tape library is not connected to the server.
Top Expert 2014
Commented:
Only suggestion I can find is to re-seat the drive and if that doesn't work place a warranty call.

 http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1276697928730+28353475&threadId=1329603