USB Modem not working

Hello experts,

I have recently received a Huawei - EC1260 modem which is used to connect to internet in my uncle's office, but it doesn't seem to work in the home pc. The home pc is Windows Vista Home Basic SP2 with the latest Windows updates installed, Intel CPU 1.73 Hz, 1.5 GB RAM, and its a 32-bit OS.

As soon as I connect this USB modem, Windows does the driver installations that are successful. There is an application called Reliance NetConnect (Reliance is the ISP that supplied this USB Modem), and this application gives an error 691: Debugger Terminated Thread.

I have tried looking within the help docs, but there is no explanation of this error in there. On doing some preliminary investigation, I've found that its an error from Windows directly. I have ensured that debugger is not switched on from within IE Advanced Options.

Any other things that I can try (also tried switching off firewall, didn't help)? Thanks in advance for any replies.
LVL 16
warturtleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jackie ManIT Manager Commented:
Use System Restore to go back to a restore point before installing your Huawei - EC1260 modem and try to install the driver in the link below in your Windows Vista Home Basic SP2.

http://forum.huawei.com/jive4/thread.jspa?threadID=330350&tstart=0&orderStr=9%22%3Ehttp://forum.huawei.com/jive4/thread.jspa?threadID=330350&tstart=0&orderStr=9

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
warturtleAuthor Commented:
Thanks for the reply, Jackieman. I will try that in a couple of hours when I will get the USB modem again and update you with what happens.
MindspielCommented:
What was uncle OS? XP?
upgrade firmware on modem, original Huawei has problems w Vista, all models
5 Ways Acronis Skyrockets Your Data Protection

Risks to data security are risks to business continuity. Businesses need to know what these risks look like – and where they can turn for help.
Check our newest E-Book and learn how you can differentiate your data protection business with advanced cloud solutions Acronis delivers

warturtleAuthor Commented:
Thanks for replying, I am not sure about the OS in his office. I will find that out. I might have to do some research about upgrading the firmware because this modem is locked to an ISP and not sure how much it can be changed or upgraded.
MindspielCommented:
No problem, i have lots of this Huawei modems, various models, best for now is K3520, no problem w Vista, 7, MacOSX
warturtleAuthor Commented:
There is an interesting twist, I also get 'Error 678: Remote Computer did not respond' sometimes. I have tried downloading the driver from the link you've supplied and tried to run uninstall to remove everything that is already installed. And then ran the installer to put in the driver again. Still get error 691 and error 678 occassionally.

My uncle doesn't know about system restore, so he is hesistant to let me do it lol.

How to upgrade firmware? And any other ideas?


warturtleAuthor Commented:
Hahaha, cannot believe it... sometimes things can be so silly.. lol..

I had tried it earlier as well, but it worked only after I updated the driver. The username and password were not correct, and my uncle had told me that same settings worked in his office, so I didn't bother looking at the username/password and concentrated on the PC itself.

It turned out that the username/password had an extra zero in the beginning, which had to be removed to make it work. I had tried it earlier with the old driver, but it didn't work. After driver was updated and the correct username and password were put in, it worked instantly!!

Thanks to both of you.

warturtleAuthor Commented:
Thanks to both of you. It feels nice to be a part of such intelligent community :-).
MindspielCommented:
nice to see your problem is solved. :-)
best to all!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.