Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Why does iPhone 3gs periodically ask for username and password when connecting to Exchange 2010

Avatar of tejicles
tejicles asked on
Exchange
5 Comments1 Solution2121 ViewsLast Modified:
Hello all....
I work in the IT department of a company that has recently deployed Exchange 2010. Exchange is published to an Edge Server protected by Microsoft TMG. All users can connect without issue, and mobile phones seem to be the only sticking point. Most mobile devices are working fine, except for the Iphone 3gs. Three users have Iphones in our company: two have 3gs and one has a 3g. The user with the 3g is not experiencing any connectivity issues but the users with the 3gs are. The 3gs successfully connect and sync with exchange (mail, calendar, and contacts) without issue most of the time. However, sometimes the iphones prompt for a password saying that the password given was incorrect. We know that it is correct, because we have successfully synced with those settings on the Iphone. Sometimes the error just says invalid user name and invalid password, but most frequently it asks for a new password. Simply canceling out of the dialog seems to work, however, it happens often enough to be irritating. Things still seem to sync fine most of the time on the 3gs but it is an irritant we would like to fix. Any help is greatly appreciated. Thanks in advance.