We help IT Professionals succeed at work.

Why does iPhone 3gs periodically ask for username and password when connecting to Exchange 2010

tejicles
tejicles used Ask the Experts™
on
Hello all....
I work in the IT department of a company that has recently deployed Exchange 2010. Exchange is published to an Edge Server protected by Microsoft TMG. All users can connect without issue, and mobile phones seem to be the only sticking point. Most mobile devices are working fine, except for the Iphone 3gs. Three users have Iphones in our company: two have 3gs and one has a 3g. The user with the 3g is not experiencing any connectivity issues but the users with the 3gs are. The 3gs successfully connect and sync with exchange (mail, calendar, and contacts) without issue most of the time. However, sometimes the iphones prompt for a password saying that the password given was incorrect. We know that it is correct, because we have successfully synced with those settings on the Iphone. Sometimes the error just says invalid user name and invalid password, but most frequently it asks for a new password. Simply canceling out of the dialog seems to work, however, it happens often enough to be irritating. Things still seem to sync fine most of the time on the 3gs but it is an irritant we would like to fix. Any help is greatly appreciated. Thanks in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Awarded 2009
Top Expert 2010

Commented:
If the account was created on the iphone prior to the migration to Exchange 2010 then I would suggest the following:

-> Delete the account from the iPhone so there are no mail accounts configured
-> cycle the power on the iPhone
-> Recreate the Exchange Account on the iPhone
-> Cycle the power on the iphone

You may also wish to check the inheritable permissions setting as per: http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/A_2861-Activesync-Working-But-Only-For-Some-Users-On-Exchange-2007-2010.html

Author

Commented:
Thank you for your comment. The account was created on Exchange 2010 first. There was no migration
from 2007. I have reset the account a number of times, but am not opposed to doing it again. Is it important to clear all email accounts first, before adding the exchange account back? Also, I have poor service at home, which is where I notice the "user name or password incorrect" or "cannot get mail" message most frequently. Sometimes, it will begin working agin, and sometimes (like today) it won't. Inheritable permissions have been checked a number of times and verified to be correct. Thanks again for your comment.......Any other thoughts would be greatly appreciated. I will try implementing your advice. In addition. I hooked up my iPhone to my computer last night to try and capture the device log for exchange when this is happening. The following is from the device log, errors which relate to activesync i believe. Maybe someone can shed some light on these:

From the console output in iPhone Configuration Utitlity from the moment I unlocked my phone this morning before it asked for my password, which it said was invalid:


Thu Jul  1 06:45:17 Thomas-Collinss-iPhone dataaccessd[146] <Warning>: EAS|ASGetOptionsTask failed: Error Domain=ASHTTPConnectionErrorDomain Code=401 "The operation couldn‚Äôt be completed. (ASHTTPConnectionErrorDomain error 401.)"
Thu Jul  1 06:45:18 Thomas-Collinss-iPhone dataaccessd[146] <Warning>: EAS|Failed to get version string
Thu Jul  1 06:45:18 Thomas-Collinss-iPhone dataaccessd[146] <Warning>: EAS|ASGetOptionsTask failed: Error Domain=DAErrorDomain Code=63 "The operation couldn‚Äôt be completed. (DAErrorDomain error 63.)"
Thu Jul  1 06:45:18 Thomas-Collinss-iPhone dataaccessd[146] <Warning>: EAS|Folder with id 1 and title Calendar has failed to sync 1 time(s) in a row
Thu Jul  1 06:45:19 Thomas-Collinss-iPhone dataaccessd[146] <Warning>: EAS|ASGetOptionsTask failed: Error Domain=DAErrorDomain Code=63 "The operation couldn‚Äôt be completed. (DAErrorDomain error 63.)"
Thu Jul  1 06:45:19 Thomas-Collinss-iPhone dataaccessd[146] <Warning>: EAS|Failed to get version string
Thu Jul  1 06:45:19 Thomas-Collinss-iPhone dataaccessd[146] <Warning>: EAS|Folder with id 1 and title Calendar has failed to sync 2 time(s) in a row
Thu Jul  1 06:46:14 Thomas-Collinss-iPhone SpringBoard[30] <Notice>: MultitouchHID(20aee0) uilock state: 0 -> 1
Thu Jul  1 06:46:14 Thomas-Collinss-iPhone MobileMail[53] <Warning>: EAS|ASGetOptionsTask failed: Error Domain=DAErrorDomain Code=63 "The operation couldn‚Äôt be completed. (DAErrorDomain error 63.)"
Thu Jul  1 06:46:14 Thomas-Collinss-iPhone MobileMail[53] <Warning>: EAS|Failed to get version string
Thu Jul  1 06:46:14 Thomas-Collinss-iPhone MobileMail[53] <Warning>: error syncing folder: Error Domain=MFMessageErrorDomain Code=1032 "The operation couldn‚Äôt be completed. (MFMessageErrorDomain error 1032.)"
Thu Jul  1 06:46:15 Thomas-Collinss-iPhone MobileMail[53] <Warning>: ERROR: MFMessageErrorDomain/Authentication Failed - The user name or password for ‚ÄúWork‚Äù is incorrect.
Awarded 2009
Top Expert 2010
Commented:
When it happens can you powercycle the phone?
I often have this problem when in a poor coverage area with my iPhone and sometimes cycling the power resolves it.

Author

Commented:
Ok thank you for your answer. The errors do seem to go away with a reset. Must just be an issue with service. Thank you again AT&T!!
Awarded 2009
Top Expert 2010

Commented:
Yes, sorry, I get this same issue with mine in bad service areas.