Slow Internet Access via Cisco 1800 Router

karl_0090
karl_0090 used Ask the Experts™
on
Hello,
I have a Cisco 1800 series router, I have configured the basics so far just to get it on the internet and allow other users to use it as there default gateway.
I have found that when browsing the internet that some pages like google.co.uk work fine, others can be slow to load some are only able to load parts and then stop but when you refresh the page the page seems to work fine until you go on another page on the site.

The internet is coming from a BT Business Hub the internet direct from there is fine, I am the only user using the internet though the Cisco router so it cannot be overloaded with requests.
I have attracted the Cisco config-file all IP addresses have been changed.
Many Thanks
Karl

Cisco1800-Config.txt
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Your LAN connection is set to half-duplex. That's not good!

It should be as shown below:
interface FastEthernet0
 description LAN
 ip address 10.1.1.252 255.255.0.0
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto

Open in new window

Author

Commented:
Hi,

It was not always set like that; I had a look round the internet for some examples to see if I had missed any settings and I found one where the LAN connection was set at half duplex.

Nether duplex auto or half duplex have any effect on it.

Thanks
Karl

Commented:
Whether you use auto or full-duplex, I would stay away from half unless you have a situation that requires it.

Author

Commented:
Hi,

So what other causes could make the Internet go slow?

Thanks
Karl

Commented:
MTU packet size and fragmentation.

from LAN host - ping -f -l 1500 IPaddress

reduce the 1500 until the ping works sucessfully.  this will determin the effective MTU of the connection.

post your results back.

Author

Commented:
Hello,

I have done that using two IP addresses one is Google and another is a forum. I don’t seem to have any trouble with Google’s website, but I did with the second IP addresses website.

At 1500 I get Packet needs to be fragmented but DF set, on both.

Once it goes to 1470 I get replies from both.

Thanks
Karl
use this command

ip nat inside soruce list 1 mypool overload

instead of

ip nat source list 1 pool mypool overload

and internet fastethernet 0 to duplex auto

Author

Commented:
Hi,

I have made the change it now reads;
ip nat inside soruce list 1 pool mypool overload

Also the duplex auto is now set.

The internet is still acting the same.

Thanks
Karl
another thing i found in ur configuration that.

you have enabled ip forward-protocol nd. if don't use the old diskless sun workstation. remove this command . because it is kind of broadcast forwarding which can cause slow internet problem.
keep the remaining configuration i told you previously. check it out

thanks & regards
vaibhav

Author

Commented:
Hi,

I have put in;

no ip forward-protocol nd

Is that the correct way to do it?
The internet is still acting the same way.

Thanks
Karl
try this command and enter the primary and secondary servers given to you

ip name-server x.x.x.x

also try to ping the isp gateway from your router see is there any packet loss or latency.

have you tried to terminate the link directly on to your pc if not chek it out.

if the problem continues then problem is at ISP side.

Author

Commented:
Hi,

I set the name-server using the IP address of the ISP, and I used the tired the address I am using as the default route 10.10.10.174.

The pings from the Cisco router to the BT one was fine and very fast no loss.

I turned the Cisco router off and sent a laptop up with the following addresses...

IP             10.10.10.173
Mask       255.255.255.248
Gateway 10.10.10.174
DNS          10.10.10.174

With the above settings in the laptop the internet worked fine.

Is my router config duplicating the above addresses?

Also the BT Business Hub is setup to do NAT ect like a standard ADSL router would that cause a problem?

Thanks
Karl
in current situation there is nat on your 1800 series router and also on ADSL router, so double nat will cause slight problem but not too much.

also are you sure that your dns is correct. cause your entering gateway and dns same ?

when you are connecting router, the wan IP from ISP is configured on ADSL/ur router ?

from your current test we are sure that the problem is with your router configuration and not the Link.

Author

Commented:
Hi,

I rang the ISP and got the DNS addresses from them, after entering them into the Cisco router there was no change I also entered in a public DNS of 4.2.2.2 still no change.

The IP addresses from the ISP are from a range of usable addresses we have to assign to servers/routers or other devices, the address 10.10.10.174 is the public IP address of the ADSL router, the address 10.10.10.173 is one from our own range other IP addresses have worked fine when assigned to servers ect...

What I am looking into doing, is setting the ADSL router into bridged mode which will just make it an ADSL modem no routeing or NAT done by the ADSL router then, this may help?

After that I think there are no more ideas...

One off topic question, I have noticed in Windows 7 that the serial port is no longer able to connect to devices such as a Cisco router has anyone heard of a fix for this?

Many Thanks for all your help and advice.
Karl
Hello,

After quite a long time researching this problem I have found that it is the LOCAL DNS servers for the network, as the network has a DHCP server which gives out addresses locally which include are local DNS server addresses when I replace them for the ones the ISP gave us the Internet works fine.

How is this problem solved as I know most networks are fine still using there LOCAL DNS with there routers connected to the Internet.

Many Thanks
Karl

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial