We help IT Professionals succeed at work.

Screen resolution limited in GNOME

jamorlando
jamorlando used Ask the Experts™
on
Hi,
I'm using Red Hat Enterprise 5.1 with Gnome 2.16 as a VMWare server.  When I go into screen resolution options, it only gives me 640x480 or 800x600 as options.  However, some applications like Logical Volume Management require larger screen resolutions.

I did some google research and people are saying to modify the xorg.conf file, however I cannot locate this file, and I'm not even sure if this will work.

Can someone please point me in the right direction?  I have only been using Linux for a couple weeks, so please bear with me.

Thanks,
Jamie
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Author

Commented:
First thing first ... I don't have a /etc/X11/xorg.conf file on this machine.
Distinguished Expert 2017

Commented:
run and post the output from lspci in a terminal window.

The information I am looking for is the Make/Model of your graphics component.
you could run system-config-display from within terminal window.

Author

Commented:
Attached is the output from lspci:

When I go into system-config-display, it is only giving me 800x600 as the maximum resolution.
lspci.jpg

Author

Commented:
Also should mention after I exitted the system-config-display utility, it created a xorg.conf file for me.  All I want is slightly larger resolution.  Any ideas?  Here is the output from the xorg.conf file.


# Xorg configuration created by system-config-display

Section "ServerLayout"
      Identifier     "single head configuration"
      Screen      0  "Screen0" 0 0
      InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
      Identifier  "Keyboard0"
      Driver      "kbd"
      Option          "XkbModel" "pc105"
      Option          "XkbLayout" "us"
EndSection

Section "Device"
      Identifier  "Videocard0"
      Driver      "vmware"
EndSection

Section "Screen"
      Identifier "Screen0"
      Device     "Videocard0"
      DefaultDepth     24
      SubSection "Display"
            Viewport   0 0
            Depth     24
      EndSubSection
EndSection

Distinguished Expert 2017

Commented:
You are in a virtual environment (VMWARE display)
Did you install the vmware tools?
You may need to alter the configuration of the virtual machine and provide a more robust display adapter?

Author

Commented:
Arnold I'll look into that, but I also have a Windows Server 2003 running in VMWare, and when I change the resolution from Windows, the window automatically resizes.
Distinguished Expert 2017

Commented:
The resolution is determine by the OS based on the information it has for the driver.

Did you install the VMWARE tools on the linux system?

The issue is not with what the 'display/graphics card supports', but what it presents to the OS.

Author

Commented:
I actually wasn't the one who set up these servers.  We had them sent to us by a client for testing.

According to the lspci output, VMWare drivers are installed.

Author

Commented:
I just checked out this site
http://www.vmware.com/support/ws3/ts/ws32ts_soundvid2.html

My xorg.conf file is set up similar to the code on this page.  I tried adding the:
Modes "640x480" "800x600" "1024x768"

But then when I opened system-config-display, it said it couldn't parse the file and it set it back to normal.

I don't have a /etc/X11/XF86Config-4.vm file ... I wonder if I should create this file with the text in this article and try that out.  What do you think?
Distinguished Expert 2017
Commented:
http://pubs.vmware.com/server1/vm/wwhelp/wwhimpl/common/html/wwhelp.htm?context=vm&file=tools_server.4.12.html

Drivers are different than the vmware tool box.

Since the linux is a VM, does it really need to run in graphical mode? And who will be accessing it in this fashion?  I think it is setup to run as a server where graphical mode is using up resources unnecessarily. i.e. usually access into the system will be via SSH rather than through the vmware console.

Author

Commented:
Thanks!