We help IT Professionals succeed at work.

receive mail from internet exchange 2007

jobby1
jobby1 used Ask the Experts™
on
I have install ed and configured exchange 2007 so that users can send and receive mails with in active directory. But user are not able to receive the emails send from the internet to our domain.Our MX record IP is 69.xx.xx.xx provide by our domin supplier. I need to confirgre the exchage to receive mail sent to usr@mydomain.com email id from out side our organization.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
http://www.petri.co.il/configure-exchange-2007-recieve-email-other-domains.htm
About half-way down he gives a step by step for adding a new accept mail from domain.
Ask you ISP to pint the MX to the ip given by your ISP.
Then nat the external ip to internal exchange ip on the firewall.
Allow anonymous users in receive connector.

Author

Commented:
R--R: I did the samething. But not receiving.How can I trouble shoot.?
Enable the firewall logs and check if the mails are hitting the firewall. Also check if the port 25 is open fro incomming mails.
If it is hitting the firewall then its a server issue, if it does not hit the firewall then it is an ISP issue.
Test the inbound mails through ttp://testesxchangeconnectivity.com

Author

Commented:
I tried the test from the http://testexchangeconnectivity.com.Test result attached.
exch.jpg
AkhaterSolutions Architect

Commented:
1) in the external DNS zone for yourdomain.com you should have an A record, say mail.yourdomain.com pointing to a public IP on your firewall (say IPx)
2) in the external DNS zone for yourdomain.com you should add an MX record pointing to mail.yourdomain.com
3) on the firewall having the public IPx port forward all SMTP traffic (TCP port 25) to the IP of your exchange server
4) in EMC -> server config -> hub transport -> find the DEFAULT receive connector -> permission tab and allow anonymous


it seems from the test results that at least step 3 is not done