User can't access IIS 6 FTP site

johnorjack
johnorjack used Ask the Experts™
on

I set up a new virtual directory in IIS under the Default FTP Site. I already have other virtual directories, and I'm able to access them with my user account, which is a domain admin. I created an account named FTPuser, gave it full permissions to the virtual directory, but I can't open the site. When I log in, I get a Success Audit event in Event Viewer, so my account is being authenticated. But the site doesn't appear, I just get the login box again.

I ran Process Monitor and saw different behavior between the two login scenarios. When I login to the same FTP site with my admin account, I get a SUCCESS result in Procmon when trying to access the folder that is specified as the home directory for my Default Web Site. But I get an ACCESS DENIED message when trying to connect as the FTPuser. Above that in the log, it also shows a NO SUCH DEVICE error trying to connect to the IPC$ share on that drive (the one containing the home directory).

When I look at the permissions, both accounts seem to have Full Control on the relevant directories. Can anyone point me in the right direction as to what is going on here?

Thanks.
 
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Maybe this applies to you:
http://support.microsoft.com/kb/830885

Author

Commented:
Thanks, but that doesn't seem like my situation.
Have you turned on logging for the FTP server? If so, can you check the logs when it fails?
How to Generate Services Revenue the Easiest Way

This Tuesday! Learn key insights about modern cyber protection services & gain practical strategies to skyrocket business:

- What it takes to build a cloud service portfolio
- How to determine which services will help your unique business grow
- Various use-cases and examples

Author

Commented:
It's giving me a 530 error in the FTP log. I know the username and password are correct; in fact, I just reset the password. I guess I don't understand why I'm seeing it try to connect to the IPC$ share of the computer that is hosting the home directory. When I connect using my regular domain account, Procmon shows something like this:

TCP Send - SUCCESS
TCP Recieve - SUCCESS
IRP_MJ_CREATE - \\homer\d$\FTP - SUCCESS

But when I try with the accounts that aren't working (note that it's not just a new account I'm having problems with; it's other accounts that have worked in the past), I get messages like the following:

TCP Send - SUCCESS
TCP Receive - SUCCESS
IRP_MJ_FILE_SYSTEM_CONTROL - \\homer\IPC$ - NO SUCH DEVICE
IRP_MJ_CREATE - \\homer\d$\ftp\ - ACCESS DENIED

Any idea what these messages mean?

Thanks.
Have you checked this link:
http://support.microsoft.com/kb/830885
I fixed this by changing the home directory of the default Web site so that it was a parent folder of the home directories specified for the individual folders beneath the default web site. Previously, it was set to a folder on a different drive. I'm not sure why that worked, but it did.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial