Installing XP as third OS on Dell Vostro 3500

Dean_S
Dean_S used Ask the Experts™
on
Spent many days trying to slipstream the Dell SATA driver into XP using nlite.  Have also tried hints and suggestions from Windows Seven Forums, including downloading suggested Intel drivers.  
Much of my problem is trying to make sense of the number of apparent driver options to try to integrate.
Sometimes I have ended up with 1.13 or 1.5+MBs to burn -tried this, and one of them would install in a VPC 2007.  When I then tried to use this disk to do a real installation in my third partition, after loading the Windows files got the message "A problem has been detected.........and Windows has been shut down ...etc".
With disks of the expected size - about 600 MB - I am still getting this blue screen.
I think the SATA driver is either not there, or the wrong one,    or??
There are now 3 DVDs and 6 CDs in the bin!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
I've used NLite to slipstream in drivers and service packs without a problem using a MS Volume License install CD for Windows XP.  I seem to recall trying at home using the Dell Windows XP Re-installation disk, and receiving a warning.

Anyways, I've received the same error you have, and after troubleshooting found that it was indeed a SATA driver issue.  I went to the Intel website and downloaded the latest Intel Matrix Storage Manager drivers, and slipstreamed those into my XP SP3 install disk, and had it work without issue.
For slipstreaming drivers, I user Driverpacks:
http://driverpacks.net/

The "Mass Storage" driverpack should have the XP driver for nearly every harddrive controller in existence.  Be sure to check "Driverpack MassStorage text mode" so that the installer can see the drive.

Author

Commented:
Thanks for the replies from marsilies and moonie 42.  It is encouraging that you have been successful.
I have Googled the sites named, but find I am uncertain about much of them.  May I digress to tell you what happened when I went to the Dell site and downloaded the SATA driver for XP (I can't get a screen shot to paste - hence the typing):-
setup.log
setup.iss
setup.inx
setup.ini
setup.exe
layout.bin
ISSetup.dll
data2.cab
data1.hdr
data1.cab
_Setup.dll
f6flpy-x86
f6flpy-x64  The x68 is 582MB.  When opened the top  5 items match those on the XP(SP3) disk, except that i386 is 452,897 bytes less.  The last three in each list are WIN51, WIN51IP, and WIN51IP.sp3.
The items in the download (R254174) that seem to include driver files are:-
desktop.ini
F6Readme.txt
iaAHCI.cat
iaAHCI.inf
iaStor.cat
iaStor.inf
iaStor.sys
license.txt
TXTSETUP.OEM    When I use nlite, and click Insert and Single, and then scroll to the R254174>f6flpyx86 and open the two .inf files appear for selection.  If I insert one, then the other can't be inserted - the message is that the .inf files are already there.
Whichever of the .inf fileI get a list of 5 with  AHCI in the name.  I select the one which shows in the Device manager in the laptop.
When the loading is done in nlite it shows 584MB plus about the same size added, giving 1.13GB or thereabouts.

Can you show any light on this confusion please?
I found this file on Dell's support site:
File Title: Rapid Storage Technology
Importance: Recommended
Release Date: 3/16/2010
Version: 9.5.4.1001, A01
Which was file R254174.exe

When extracted, I see the f6flpy-x86 folder, which is 466KB large. The only files in that folder are:

F6Readme.txt
iaAHCI.cat
iaAHCI.inf
iaStor.cat
iaStor.inf
iaStor.sys
license.txt
TXTSETUP.OEM
If you have other files in that folder, then something got messed up, possibly by NLite. I think it copies the original source directory to a destination, maybe you accidentally pointed it to f6flpy-x86 as a destination at some point, hence the doubling-up of files and space.


I never like NLite. For slipstreaming hotfixes, I use RVM Integrator, and for drivers I use Driverpacks. Driverpacks is great because I don't have to care about finding the specific driver for whatever hardware I'm installing, since the Driverpacks have nearly all of them.

Author

Commented:
Thank you to Marsilies.  I successfully made bootable CD with Sata drivers - I put those you listed in a separate folder, so that the f6flpyx86 was not included by nlite.  However I regret to report that my attempts to end with both W7 and XP bootable did not work out.

I installed XP satisfactorily -  but noticed that when the unpartitioned space was selected , and C was pressed to create a partiton in it, that the Dell partitions and that for W7 changed to one larger partition, apparently empty.  When I did a restart from XP, the W7 /XP choice did not show - it went straight to XP.

 I then reinstalled the two Dell partitions and W7 from a backup I had earlier put on an external drive. Used EasyBCD 2.0 to load ntldr for XP.  Both OSs then showed.  W7 was normal.  XP however stopped at the Welcome screen/loading your settings EXCEPT the words were missing - only the XP icon etc was there.

I tried again, this time pressing F8, but the window was unchanged - that is, F8 did not work.

This seems to be like Catch 22.  I can have one or the other.  I can't see a way past this, so will reluctantly settle for XP Mode in W7.
It's a good thing you made the backups, otherwise your situation could be much worse.

The XP bootloader does not play well with later versions of Windows. When I created a dual-boot between XP and Vista, with Vista installed first, I decided to hide the Vista and other partitions first, so that XP would only see its own partition when installing. I used a partition manager on a bootable CD like Parted Magic:
http://partedmagic.com/

When XP was successfully installed, I then booted Parted Magic again and unhid the Vista partition. I then used EasyBCD to add the XP partition to the Vista bootloader.

Author

Commented:
I have a clearer idea of what happened now.

Although I had seen that the two Dell partitions were each "Primary", I did not recall that at the time when I selected the unallocated part of the disk and then C to forma partition.  As there were already 4 because I also had W7 and Vista, it seems that to create the new one the XP installation files then wiped the others!

I have now got just W7 and Vista, with XP Mode in W7.

I suppose I don't need the Dell Recovery partition - I have the disk and also backups - but I think I will stay as I am for the time being.

Author

Commented:
The question that I had was really rather convoluted, as I was feeling my way quite a bit.
For this reason we did not get a full match between us - never-the-less, thanks to all and apologies for my lack of precision.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial