We help IT Professionals succeed at work.

Exchange 2007 RPC mail - mutual authenticate

Nova Consult ApS
Nova Consult ApS used Ask the Experts™
on
Hello all

I have a exchange server 2007(windows 2008 sbs) where i cant get the RPC mail to work like all my other exchange 2007 servers.

the problem is that when i select the "mutual authenticate the session when connection with ssl" in the outlook confik it just keep asking for username and password, but if i remove this all seams to work, but i'll lige to use this because all my other server does this :-)

is there any way for me to check what is wronk ??

the only think i have changed on this server is the exchange certificate.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hi Nova-C,

It probably is something with the certificate.
Is the client machine XP? If you entered a Certificate Principal Name, and the certificate has the name as an alternate name, XP will not connect properly. Vista and 7 are smart enough to do this anyway.
It also can be that the certificate is not trusted and needs to be imported. The easiest way to check this is browsing to the URL and see if IE comes up with a warning about the certificate.

Regards,
BB
Nova Consult ApSIT Cunsult

Author

Commented:
ie works and the certificate is imported and enabled
the remote.xxx.com website works fine and the alternate names in the certificate seams to work also
Commented:
Run the Below Command :-

Set-OutlookProvider EXPR -CertPrincipalName msstd:mail.domain.com  (Note - msstd : Issue to name on the Certificate)

Set-OutlookProvider EXCH -CertPrincipalName msstd:mail.domain.com

Set-OutlookProvider Web -CertPrincipalName msstd:mail.domain.com
Nova Consult ApSIT Cunsult

Author

Commented:
anwarS: Thx alot that worked after i changed the principle name  in the certificate to remote.xxx.xx
before i had autodiscover.xxx.xx

Commented:
are you wish to use RPC over https (outlook anywhere in E2K7) ?