We help IT Professionals succeed at work.

Slow Access from XP to 2008 R2 Server

networkn
networkn used Ask the Experts™
on
Hi There!

We have a network which was recently migrated from Netware 6.5 to Windows 2008 R2. All the workstations were existing except 2 identical PC's one with XP and the other with Win7 Pro 32 Bit.

All the XP Machines including the new are complaining about slowness in a particular app, which was running fine before the migration. I called the Vendor (MYOB) who said, that it was a known issue but couldn't give me specific information. I believe it relates to a registry entry or a tuning option which isn't compatible between 2008 r2 and XP,  

The application is MYOB Accountants Office Enterprise.

The Win7 Machine is running fine.

Other than the one application (Not client server), the XP Machines can access the network fine it would seem, just this one application.

Anyone know what the setting(s) might be?

it's a 100Mbit Network. 12 Workstations.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Maybe this is the problem:
http://support.microsoft.com/kb/296264
IT Regional Manager - UK
Commented:
you could also try disabling SMB2.1 on the 2008 server, as XP can only communicate in SMB1.0.  I'll paste a text file i have below:


So, for troubleshooting purposes, mostly in an environment that has mixed operating systems, you might want to consider disabling SMB 2.0. You need to do so on both the "client" and the "server" operating systems. To disable SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems run the following commands:

sc config lanmanworkstation depend= bowser/mrxsmb10/nsisc config mrxsmb20 start= disabled

Note there's an extra " " (space) after the "=" sign.

To enable back SMB 2.0 for Windows Vista or Windows Server 2008 systems that are the “client” systems run the following commands:

sc config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsisc config mrxsmb20 start= auto

Again, note there's an extra " " (space) after the "=" sign.


In order to disable SMB 2.0 on the server-side computer, follow these steps:
Warning!

This document contains instructions for editing the registry. If you make any error while editing the registry, you can potentially cause Windows to fail or be unable to boot, requiring you to reinstall Windows. Edit the registry at your own risk. Always back up the registry before making any changes. If you do not feel comfortable editing the registry, do not attempt these instructions. Instead, seek the help of a trained computer specialist.

   1. Run "regedit" on Windows Server 2008 based computer.
   2. Expand and locate the sub tree as follows.

      HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters

   3. Add a new REG_DWORD key with the name of "Smb2" (without quotation mark)

      Value name: Smb2
      Value type: REG_DWORD
      0 = disabled
      1 = enabled

   4. Set the value to 0 to disable SMB 2.0, or set it to 1 to re-enable SMB 2.0.
   5. Reboot the server.


Author

Commented:
Sorry for the delay, yes this seems to have solved my xp to 2008 problems. The problem is now my Win7 is slower than it was. Any way to get both working quickly?
Iain MacMillanIT Regional Manager - UK

Commented:
Disable IPv6 on the Win 7 NIC and the IP Helper service (for IPv6).

remember you may need to disable SMB2.0 on the Win 7 box too.

Author

Commented:
Hi There!

I really apologize, I didn't get notification I'd had this reply. I will give that a go and see how I go with it in the next few days.
Iain MacMillanIT Regional Manager - UK

Commented:
no worries, just keep in touch to see if its resolved.

Author

Commented:
Great thanks very much!

Commented:
I wanted to add that the accepted answer WORKED for my problem! For me, XP clients connecting to a Windows Server 2008 were VERY slow compared to the Windows 7 machines regardless of the hardware. I tried many fixes but the Accepted Solution was the main reason this was solved.
Other things I did, that may or may not be good to try are: disabling IPv6 (some say not to), Disabling TCP and IP Checksum and Offloading in the adapter properties.  I also disabled the 2nd network adapter.
Just wanted to add my experience. Thanks for the fix  IainNIX!

Author

Commented:
Don't EVER disable IPV6 on 2008+ servers, or next time you reboot, be prepared for a 2 hour boot time.
Iain MacMillanIT Regional Manager - UK

Commented:
no you would normally only disable IPv6 on the client Win 7 systems, but i gave the whole sequence so as to not miss any information.  the slow link speed is normally an issue @ the client end.

The other features to disable/enable on Win 7 will also help most networking:

netsh interface tcp set global autotuninglevel=disable        [can speed up logon times]
netsh int tcp set heuristics disabled         [keep disabled to retain autotune setting]
netsh int tcp set global congestionprovider=ctcp    [off by default, but increases TCP send window and works from Vista onwards, though there is supposed to be a hotfix for XP/2003, highly recommended its turned on)