R8.5.1, Rich Text JavaScript Control not working on the server

sloeber
sloeber used Ask the Experts™
on
I'm trying the JavaScript Control option when you create a new rich text field.
On the server, I see in the browser just the standard rich text box and not the dojo one.
When I do the same local I see the rich text  field with the javascript control (dojo).

I dont know what's wrong, all the dojo classes are available on the server.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
You have to check that js-includes in your HTML or generated code are available.
You can try to load these resources in browser (may be this files have not permissions to read on server?).
Example:
http://yourhost/yourcontext/scripts/somescript.js is available but in your page:
<script src="scripts/somescript.js"> can be available not in all cases.
Use full paths.

Author

Commented:
Javascript Control is a standard propertie for a rich text field.
So, it's not necessary to include manually extra code.
When I copy the db local, eveything works fine.
When I do a "view source",  I don't see something about js or dojo or .........
Local, I see for the same db the extra code.
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

Author

Commented:
nope, it's just a standard form with a rich text field in.
so the url is something like http://myserver/apps/test/dojotest.nsf/formtest
Create a new form with a rich text field
In that rich text field, I've checked in the field properties for  WebAccess Display: Using JavascriptControl

That's all.
It works local and it works on my test machine, but on the  production server, I see just the standard rich text field layout.
I've check the server configuration document and the dojo paths but they are the same for both.
Sjef BosmanGroupware Consultant

Commented:
Dojo only works with XPages. If you want the Java Applet though, you have to enable it in the form's settings.
Sjef BosmanGroupware Consultant

Commented:
Ehhh... I might be wrong there, apparently it's a new option... The Domino server, is it R8.5 ?

Author

Commented:
sorry sjef but that not true.
Check this
http://www.codestore.net/help/help85_designer.nsf/89d3962efd85426f85256b870069c0aa/be06c524609738dd852574cf006b27c9?OpenDocument
I've enough examples to show you that it also work with forms (R8.5.1)
It's an extra propertie in a rich text field.
It's the standard dojo from domino.
Just try it, and you'll see it.
Like I said before when I make a replica from my db on one server it works and on the other server it doesn't work.
But why ? That's the question.
Sjef BosmanGroupware Consultant

Commented:
> That's the question.
I really don't like that programme...

You did see the other question I asked? About Domino versions?

Author

Commented:
All the versions are the same(8.5.1) on all the servers, but it works on some servers and on other servers it doesn't work
Sjef BosmanGroupware Consultant

Commented:
*scratching head*

Clueless...
Commented:
Found the problem.
The problem was that we copied a new dojo version  in the js directory.(version 1.42)
The standard version is 1.32  and we leave that also in the directory.
But, the new dojo 1.42 that we downloaded from the web hasn't got a IBM directory, and that's the directory domino  needs for the standard javascript control.


Sjef BosmanGroupware Consultant

Commented:
*scratching head again*

Baffled... I hope that it is your test environment?  ;-)
Sjef BosmanGroupware Consultant

Commented:
That's seems like dubble trubble ;-))

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial