Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

Troubleshooting
Research
Professional Opinions
Ask a Question
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

troubleshooting Question

Removable devices - show up on some machines, not on others!

Avatar of Chris Millard
Chris MillardFlag for United Kingdom of Great Britain and Northern Ireland asked on
.NET ProgrammingWindows VistaWindows 7
4 Comments1 Solution395 ViewsLast Modified:
There are 3 PCs at my office - 2 HPs and 1 Acer. All 3 machines have inbuilt card readers. My HP and the Acer both run Window 7 Enterrpise. The second HP runs Vista.

In explorer on my PC. In the left hand pane, I see my local disks, my DVD and mapped network drives. I do NOT see the removable drives as there is no media inserted into any of them - BUT they do show up in the right hand pane under the Devices with Removable Storage section with the drive letters assigned.

On the Acer and the other HP, these Devices with Removable storage also show up in the left hand pane (with their drive letters) inbetween the local discs, DVD and mapped network drives - even though there is still no media inserted.

Why would this be? This doesn't sound like much of a problem, except for that I am writing a program that tries to access partitions based on their GUID. On my machine, the removable devices are ignored unless they have media inserted, and on the other 2 machines, I get an error message because there is no media inserted!

Any thoughts?
ASKER CERTIFIED SOLUTION
Avatar of Chris Millard
Chris MillardFlag of United Kingdom of Great Britain and Northern Ireland image

Our community of experts have been thoroughly vetted for their expertise and industry experience.

Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answers