We help IT Professionals succeed at work.

Windows 2003 SP2 server in a workgroup keep going back 1 hour every 15 minutes

systemmanagement
systemmanagement used Ask the Experts™
on
Hi,

Could someone help me on this issue?

I am having a Windows 2003 SP2 server in a workgroup. Clock on this server automatically goes back to 1 hour comparing to other servers in the same site.

Troubleshooting done sofar:
===================
1. Changed the SNTP Server to itslef, Time zone was set correctly.
2. Changed in the registry on NTP server to its IP address.
3. Ticking or unticking Automatically adjust day light saving option doesn't help
4. We see an error failed to syncronize with windows time server and also by selecting DC and clicking on update.
5. Stopped windows time service, and changed the time manually, still it goes back to 1 hour.

No luck sofar.

Thanks in advance,

Regards,
Nirmal
2.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Refer to these links:  http://blog.techscrawl.com/2008/08/12/server-2003-ntp-time-sync-troubles/
http://support.microsoft.com/kb/875424

These two articles should provide you with the solutions you need.

Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
you would do well to install the 2010 timezone fixes from microsoft

fill out this little form and it'll give you the downloads you need
http://support.microsoft.com/gp/dst_it1

Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
oh sorry - i meant to say, you can adjust the NTP settings all you want, fact is, some of your equipment have incorrect time zones.  apply the fixes i noted above, and make sure your problem devices have the correct time zone set (after the updates)

Author

Commented:
Hi Bryon,

Thanks for the links. I have downloaded the hof fix, it gives the following versions:

Tzchange.exe 5.2.3790.4017 60,928 06-Feb-2007 12:37 x86 SP2 SP2GDR
Tzchange.exe 5.2.3790.4017 60,928 06-Feb-2007 14:42 x86 SP2 SP2QFE

But the version already available (5.2.3790.4552) is latest than in the hot fix. I guess I will not be able to install the hot fix on the server.

Could you please give me the next action plan or ideas?

Regards,
Nirmal

Commented:
You could always use a 3rd party app like Atomic Clock Sync (download from http://download.cnet.com/Atomic-Clock-Sync/3000-18512_4-14844.html?tag=mncol) and put it on a 30-45 minute sync schedule.
Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
synchronizing the clock isnt the problem, the time zone is.

one server says "it is eastern gmt-5 is 1pm, everyone be like me"
the server not complying is changing itself because it thinks "he's wrong, eastern is -4 so i'll just adjust myself"

the naming and order of the time zones were changed and if all servers don't agree on the name, they take their own best guess.

i'd like you to see if your server already has this applied:
http://www.microsoft.com/downloads/details.aspx?FamilyId=feb0f2ac-7f22-4e33-8313-af4f3ce38177&displaylang=en


Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
the kb article on the download link has a lot more technical info about why it's happening

Author

Commented:
Thanks for the information. I will try the suggestions and getback to you.

Regards,
Nirmal

Author

Commented:
Hi,

I have tried the above hot fix, the issue still persist. Please let me know the next steps.

Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
well, every 15 minutes seems like the time it would check in with time.windows.com... are you sure you have the right time zone selected on the server?

can you disable the windows time service?  
start > run > services.msc
find windows time, double click, disable it, stop it... wait 15-30 minutes and see if the time stays good

Author

Commented:
Hi Bryon,

I tested stopping windows time service, but it still go back to one hour. I have seclected the correct time zone, as this server is in workgroup and no internet access, no communication with other server, i guess this server is not syncronizing with time.windows.com or with DC.

I am suspecting if the BIOS time is wrong or CMOS battery might be faulty. I will disable to windows time service again and update you.

Please let me know if there are any more steps that i can test.

Author

Commented:
Hi Bryon,

I have disabled windows Time service and set the time correctly (1 hour ahead) in three minutes the time changed automatically back to 1 hour late.

Please share any more ideas. Thank you.
Bryon HSenior Technical Support Analyst
Top Expert 2010

Commented:
well, it is pretty common for this to happen... at this point you can mess around with the NTP command line for a few days and it still won't work... or you can install this free software here:

http://freestone-group.com/fg-time-sync.htm

it runs as a service, only takes a few KB of memory and will keep your clock in sync every minute

usually people install the server version on a server, and tell it to sync with one of the built-in external time providers.
then they install the client version on any problem workstations, and set the workstations to sync with their own server.

but you can certainly install just the server version on your server if that's the only machine having a problem

Author

Commented:
Still not resolved Yet
Bryon HSenior Technical Support Analyst
Top Expert 2010
Commented:
have you tried my link above?
Hi,
Resolved the issue. Thanks for your suggestions.

Author

Commented:
The issue is resolved by uninstalling a third-party service running on the box.