We help IT Professionals succeed at work.

Cisco Router DHCP Settings

corecc
corecc used Ask the Experts™
on
Hi Experts

I've just purchased a Cisco Small Business pro SRP 527w and cant work out how to disable DHCP. I assuming I need to disable DHCP as the router will be connected to a SBS 2008 server. I have found some instructions on-line about how to disable it using a telnet connection, however when I try to connect I get the following error:

Could not open connection to the host, on port 23: Connect failed

Any ideas?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Mike ThomasConsultant
Top Expert 2010

Commented:
You will need to connect to the router via the serial (blue cable) to the console port to run the initial setup of your router.

Mike ThomasConsultant
Top Expert 2010

Commented:
Here are some instructions on using the console cable.

http://www-tss.cisco.com/eservice/compass/common/tasks/task_console_port_connect.htm
Mike ThomasConsultant
Top Expert 2010

Commented:
Actually having just looked at this router is it out of the box configured?

If it is handing out DHCP info are you trying to connect to the ip address of the default gateway? Also have you tried using your web browser to connect to it?

Author

Commented:
I can connect using a web browser, I just can find any settings to disable DHCP, the instructions mention where the option is but the option isnt there, it dosent even show up in the screen shot in the manual.
Mike ThomasConsultant
Top Expert 2010

Commented:
Maybe this will help

STEP 1 Click Interface Setup on the tab and then click LAN in the navigation pane. The
DHCP Server page appears.
STEP 2 You can edit or delete a DHCP entry by clicking the edit or delete icon.
STEP 3 Click Add Entry to open the DHCP Add page. From this page you can add a DHCP
entry.
STEP 4 Click Submit to save your settings.

Taken from page 56 of this document

http://www.cisco.com/en/US/docs/routers/srp520_series/srp521w/administration/srp500_admin.pdf
Mike ThomasConsultant
Top Expert 2010

Commented:
Search that Document for the Term "DHCP Server"

Page 58 is worth a read too as it states that DHCP is enable by default but if you already have a DHCP you can disable it.

The Screen shot looks like the same sub menu as the one on page 56 of that doc so read those pages and navigate those menus untill you find the diable option.

Author

Commented:
Thanks for your help on this, that's where I've got to with it, the option isnt there.
Mike ThomasConsultant
Top Expert 2010

Commented:
Are you able to update the firmware?

Author

Commented:
unfortunately not, I need to have a support contract to get the latest firmware. I think I'm going to need to send it back.
Mike ThomasConsultant
Top Expert 2010

Commented:
Mmm only other thing I can think of is to check you are logged in as an admin not a lesser account, if that's even possible.

Author

Commented:
Got it, after 2 hours on the phone to technical support finally worked it out. Under DHCP you edit the profile and change option 66 to none, this disables DHCP, no mention of this in the user manual, anyway thanks mojo for your help, hope this helps someone else.

Author

Commented:
I thought tech support had fixed it but dhcp is back on now, so still no idea.

Author

Commented:
I thought tech support had fixed it but dhcp is back on now, so still no idea.
Mike ThomasConsultant
Top Expert 2010

Commented:
Is there anything in the config that allows you to enable telnet or ssh so you can connect like you were trying to earlier?

Commented:
Look at this document http://www.cisco.com/en/US/docs/routers/srp520_series/srp521w/administration/srp500_admin.pdf

On page 56 it describes DHCP management.
If your interface is different, please provide us with a picture

Author

Commented:
Thanks Serhiyko for you comments, I have the same manual and my interface looks the same as the manual screen shot, the problem is there simply is no option to disable dhcp, the only possibility I could see was to set maximum number of DHCP allowed to 0, but this isn't allowed you have to enter at least 1.

Commented:
You can try creating a small DHCP scope with only one address and then reserve if for a "dummy" computer.

Author

Commented:
Yep could do that, SBS would still pick up on the fact that another DHCP server was running even though it wouldnt be causing a conflict, don't know whether it would let me do this or not.

Commented:
corecc: I see your point. What if you try creating a scope with a different subnet range?

Commented:
So, on the LAN side of the router, there is no setting to disable DHCP?

Author

Commented:
Yep correct, that's the problem.
Commented:
Problem solved, in a nutshell you cant disable DHCP on the lan so you have to create a vlan with a static IP instead of DHCP server, this works fine with the SBS. The only other thing to do then is to setup your port forwarding under nat.

Commented:
Blimey!  I'm in the same boat.

Can you give me any pointers on how to setup the V-Lan? I have SBS2011 running exchange and RWW for remote users and in a bit of a pickle with the SBS not liking the DHCP server's presence.