Exchange 2010 OWA slow

wsani
wsani used Ask the Experts™
on
Hi,

I've setup our CAS/Hub array with 4 VM server (2 on each VM server). These hosts have only the C/H roles, and I've configured the array using EMC.

I've created the VIP on our ServerIron, and I have it running. That said, when I go to the FQDN (VIP), it connects to the internal IP address (s) properly, and I'm able to log-in but, OWA is very slow and I often experience what seems to be session related issues.

Any thoughts how I should go about troubleshooting this?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®

Commented:
Disable IP6
1.      In Registry Editor, locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters\
2.      Double-click DisabledComponents to modify the DisabledComponents entry.
Note If the DisabledComponents entry is unavailable, you must create it. To do this, follow these steps:
a.      In the Edit menu, point to New, and then click DWORD (32-bit) Value.
b.      Type DisabledComponents, and then press ENTER.
c.      Double-click DisabledComponents.
1.      Type any one of the following values to configure the IPv6 protocol, and then click OK:
a.      Type 0 to enable all IPv6 components.

Note The value "0" is the default setting.
b.      Type 0xffffffff to disable all IPv6 components, except the IPv6 loopback interface. This value also configures Windows Vista to use Internet Protocol version 4 (IPv4) instead of IPv6 in prefix policies.

Make sure you have plenty of memory

Commented:
Also make sure to disable any nics it isn't using.
Awarded 2009
Top Expert 2010

Commented:
DO NOT DISABLE IPv6 this has nothing to do with it and will not help!

This is a known issue and it's resolved with Exchange 2010 Service Pack 1 which is currently available as a beta and is due for release later this year.
11/26 Forrester Webinar: Savings for Enterprise

How can your organization benefit from savings just by replacing your legacy backup solutions with Acronis' #CyberProtection? Join Forrester's Joe Branca and Ryan Davis from Acronis live as they explain how you can too.

Author

Commented:
IPv6 is unchecked on the NIC. That's as far as I'm going to go with it. There is no sense in hacking the registry. These are VM guests, and they've been allocated at least 8GB of RAM each. Additionally, there isn't any load on the server since I'm still testing it out.

Thank you demazter!
Awarded 2009
Top Expert 2010

Commented:
You need IPv6 for Exchange 2010 to work so please ensure this is checked on the NiC

Author

Commented:
Done.
Awarded 2009
Top Expert 2010
Commented:
Other than that there is little we can do I am afraid, like I said, it is a known issue and it's been resolved in SP1 for Exchange 2010.

The Beta is available here: http://www.microsoft.com/downloads/details.aspx?FamilyID=a0965fc9-2723-4947-ae6b-74bc3808e72a&displaylang=en if you have a test system you want to check it out on.

The Exchange beta's are normally excellent but I would suggest anyone tries to run them in production as they are unsupported.

Author

Commented:
Sigh. I haven't even gone into production :) Thanks for the input and advice!

Commented:
Just an  FYI - I have four clients with Exchange 2010 servers and they miraculously work without IP6.  IP6 can cause quite a few issues depending on your environment.  FYI OWA performance is fine except after a reboot - the very first person to go into OWA will experience slowness until their e-mail is visible.

Author

Commented:
I had IPv6 disabled, and it worked. That said, I also discovered that if I set our ServerIron to sticky instead of round-robin, I get a much better performance out of it. I'm happy with the results...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial